Opened 10 years ago

Closed 9 years ago

#8004 closed enhancement (fixed)

Add a friendly error popup when checkTimeZone() fails during startup

Reported by: Johnny Walker <johnnyjboss@…> Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: MythTV - General Version: 0.22-fixes
Severity: medium Keywords: checkTimeZone friendly popup error
Cc: Ticket locked: no

Description

To lesson the frustration of new users I've suggested and implemented a MythConfirmationDialog? to send users to review their logs in relation to the time zone mismatch.

Prior to this popup it would appear that mythfrontend would crash when it exited right after being started.

Attachments (3)

main_rev23251_diff.cpp (894 bytes) - added by Johnny Walker <johnnyjboss@…> 10 years ago.
svn diff of programs\mythfrontend\main.cpp
backendconnectionmanager.cpp_23424_diff (1.1 KB) - added by Johnny Walker <johnnyjboss@…> 10 years ago.
svn diff of changes in mythtv-trunk/mythtv/programs/mythfrontend/backendconnectionmanager.cpp
backendconnectionmanager.cpp_r23487.diff (1.3 KB) - added by Johnny Walker <johnnyjboss@…> 10 years ago.
The correct diff for .23 (trunk)

Download all attachments as: .zip

Change History (5)

Changed 10 years ago by Johnny Walker <johnnyjboss@…>

Attachment: main_rev23251_diff.cpp added

svn diff of programs\mythfrontend\main.cpp

Changed 10 years ago by Johnny Walker <johnnyjboss@…>

svn diff of changes in mythtv-trunk/mythtv/programs/mythfrontend/backendconnectionmanager.cpp

comment:1 Changed 10 years ago by Johnny Walker <johnnyjboss@…>

I mistakenly left out the necessary includes to compile the backendconnectionmanager in trunk (.23)

I'm glad there seems to have been no activity on this ticket.

Changed 10 years ago by Johnny Walker <johnnyjboss@…>

The correct diff for .23 (trunk)

comment:2 Changed 9 years ago by robertm

Resolution: fixed
Status: newclosed

(In [24037]) Fixes #8004. Add a MythUI popup when backend and frontend timezones are mismatched to present a "friendly" notification of exactly what the problem is. Original patch by Johnny Walker with some modifications for coding standards/variable naming/a little cleanup by me.

As an aside, this kind of minor user friendliness fixup is incredibly appreciated when we see it coming from users, and I will make every effort to review this kind of patch quickly.

Note: See TracTickets for help on using tickets.