Opened 10 years ago

Closed 10 years ago

#8009 closed patch (fixed)

Arclight schedule-ui.xml. Changeset 23343 fixed bug for endoffset as per ticket #7980, but introduced equiv bug for startoffset

Reported by: grokky Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: Themes Version: head
Severity: medium Keywords: Arclight schedule-ui.xml
Cc: Ticket locked: no

Description

negative and positive are now reversed for startoffset in Arclight schedule-ui.xml.

Changeset 23343 fixed labels in spinbox for endoffset, but mistakenly changed startoffset labels which were already correct. (ticket #7980 only referenced a bug for endoffset)

startoffset seems to be "startearly", so a positive value starts the recording early, whereas endoffset seems to be "end late" so a positive value ends the recording later, rather than both being a set offset from the scheduled start/stop time.

Have not looked at the code, just the theme xml, and confirmed sensible values on my system - trunk (23357) and sensible values in DB.

May want to double check my logic is correct before committing.

Patch attached.

Attachments (1)

startoffset_patch (788 bytes) - added by grokky 10 years ago.

Download all attachments as: .zip

Change History (2)

Changed 10 years ago by grokky

Attachment: startoffset_patch added

comment:1 Changed 10 years ago by robertm

Resolution: fixed
Status: newclosed

(In [23421]) Close #8009.

Note: See TracTickets for help on using tickets.