Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#8035 closed defect (invalid)

MythArchive: temp.m2v is null sized

Reported by: Florian R. <qeldroma@…> Owned by: paulh
Priority: major Milestone: unknown
Component: Plugin - MythArchive Version: 0.22
Severity: high Keywords: mpeg2enc temp.m2v size 0
Cc: Ticket locked: no

Description

I got this now in v0.22 and before in v0.21!

Everytime i want to burn a dvd with menus, the process breaks. Only without menus is working..

I attached the log-files, afaik there is a problem before mplex is called because the temp.m2v file is blank?

I am after this now for more than 9 months, would be great to receive some usefull hints to solve this ;)

Thanks, Florian

Attachments (5)

dvd-dir.jpg (26.6 KB) - added by Florian R. <qeldroma@…> 10 years ago.
mythburn.log (27.4 KB) - added by Florian R. <qeldroma@…> 10 years ago.
progress.log (4.4 KB) - added by Florian R. <qeldroma@…> 10 years ago.
progress.2.log (4.8 KB) - added by Florian R. <qeldroma@…> 10 years ago.
This is with projectX
mythburn.2.log (33.6 KB) - added by Florian R. <qeldroma@…> 10 years ago.
This is with projectX

Download all attachments as: .zip

Change History (12)

Changed 10 years ago by Florian R. <qeldroma@…>

Attachment: dvd-dir.jpg added

Changed 10 years ago by Florian R. <qeldroma@…>

Attachment: mythburn.log added

Changed 10 years ago by Florian R. <qeldroma@…>

Attachment: progress.log added

comment:1 Changed 10 years ago by Florian R. <qeldroma@…>

PS: This example was a project with two videos i wanted to burn. Nevertheless, if i take only one video for dvd, result's the same.

And it's the same, too, if i take another theme. All themes with menus fail, so i would bet there's some problem with menugeneration.

comment:2 Changed 10 years ago by J.Pilk@…

It's failing at the menu generation stage because that's the first time it tries to read the null m2v file. mythburn.log also shows a wrong audio frame size, and in my experience that would make sound fail. Using ProjectX as the demuxer in mytharchive might work - it's a lot more tolerant of errors in the input streams.

comment:3 Changed 10 years ago by Florian R. <qeldroma@…>

Tried it now with projectX, but same result. What i am wondering is, what this mysterical temp.m2v is for? And at which step is it created? If i grep the logfiles for that filename, i get it only at the end in the error-message? So where is the step in the logs, where this file should be done?

Changed 10 years ago by Florian R. <qeldroma@…>

Attachment: progress.2.log added

This is with projectX

Changed 10 years ago by Florian R. <qeldroma@…>

Attachment: mythburn.2.log added

This is with projectX

comment:4 Changed 10 years ago by robertm

Guys, please take the back-and-forth discussion to the mailing lists.

comment:5 Changed 10 years ago by paulh

Resolution: invalid
Status: newclosed

The bug is actually in one of the tools used by MythArchive?. In this case it's the jpeg2yuv program which is used in the process of creating the menus. I know that at least the Gentoo version of that tool has problems no idea if it affects other distros.

If any Gentoo user has this working I'd love to know what version of media-video/mjpegtools and media-libs/jpeg you are using.

Closing as invalid since it's not a bug in MythArchive?.

comment:6 Changed 10 years ago by paulh

If you want to verify this is the same problem you can run this from the command line (just change background-1.jpg to point to a jpeg image you have).

jpeg2yuv -n 300 -v2 -I p -f 25 -j 'background-1.jpg' > temp.m2v

comment:7 Changed 10 years ago by Florian R. <qeldroma@…>

Thanks! That was a great hint!

After rebuilding the jpeg-package, all went well!

Cheers, Florian

Note: See TracTickets for help on using tickets.