Opened 10 years ago

Closed 9 years ago

#8048 closed defect (fixed)

Frontend segfault after deleting video when browsing by metadata

Reported by: jason.chambers@… Owned by: Anduin Withers
Priority: minor Milestone: unknown
Component: Plugin - MythVideo Version: 0.22-fixes
Severity: medium Keywords:
Cc: Ticket locked: no

Description

After deleting a video and then pressing escape to go back a level MythFrontend segfaults.

The segfault does not happen until I press "Escape" to go back a level. i.e. I can continue to browse/play/delete other videos without problem before pressing "Escape", but when I go back up a level the segfault still occurs.

This *only* happens when browsing the videos by one of the new "Metadata Browse Modes". If I delete a video using the older folder browsing method it *does not* segfault.

This happens in Broswe, Gallery & Manage views but not the List view. The List view is the only view where pressing "Escape" takes you out of MythVideo? and back to the menu - in all the other views pressing "Escape" just takes you back up a level (e.g. from the list of films back to the list of Genres or Cast etc).

This is reproducible every single time.

It occurs regardless of whether the deleted video was in a Storage group or a normal filesystem directory. It also occurs regardless of whether its the only video in the Genre (or Cast etc) group.

Attached is a backtrace. This is using the Browse view, browsing by Genre and deleting 1 video from the "Drama film" group which contains 75 other videos. The video was in a Storage Group.

NB I have seen #7056, but the changes for this are already part of 0.22-fixes and it still occurs.

Attachments (1)

mythvideo_segfault.txt (26.3 KB) - added by jason.chambers@… 10 years ago.
gdb backtrace from MythFrontend

Download all attachments as: .zip

Change History (2)

Changed 10 years ago by jason.chambers@…

Attachment: mythvideo_segfault.txt added

gdb backtrace from MythFrontend

comment:1 Changed 9 years ago by robertm

Resolution: fixed
Status: newclosed

I meant to close this a few days ago-- I am unable to reproduce, but AFAICT this was caused by a null type being passed to the GetFirstImage? function. When I added mass metadata grab I added a check for null type. Should be fixed in trunk and the forthcoming .24.

Note: See TracTickets for help on using tickets.