Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#8076 closed defect (invalid)

Solid-color preview with RTJPEG in NUV recordings/transcodes

Reported by: marco.wallerstein@… Owned by: danielk
Priority: minor Milestone: unknown
Component: MythTV - Recording Version: 0.22
Severity: medium Keywords: Preview, solid color, RTJPEG, NUV
Cc: Ticket locked: no

Description

After editing (cutting) a recording the preview picture is updating to the cutted part of the recording, meaning it shows a picture of the recording from beginning + a couple of seconds.

When this cutted record is transcoded in order to cut off the unneeded parts of the record, the preview picture is not showing something anymore. At least it doesn't show a preview of the record, but just a one color block.

Change History (6)

comment:1 Changed 10 years ago by sphery

Anecdotal evidence from the lists seems to indicate this is only a problem with RTJPEG in NUV recordings or transcodes. See threads at http://www.gossamer-threads.com/lists/mythtv/users/365961#365961 and http://www.gossamer-threads.com/lists/mythtv/users/407873#407873 .

comment:2 Changed 10 years ago by danielk

Milestone: 0.23unknown

comment:3 Changed 10 years ago by marco.wallerstein@…

Thanking to the comment of mdean I changed meanwhile transcoding profile from RTJPEG to MPEG. Here the problem doesn't happen, everything just works fine! So if RTJPEG is anyhow removed in future (?) I don't see a reason to follow up this ticket anymore. Maybe it would just be a good idea to have MPEG as the default profile setting for future releases?

comment:4 Changed 10 years ago by sphery

Status: newinfoneeded_new

I was unable to reproduce this issue on current trunk after transcoding a MPEG-2 recording to RTJPEG in NUV. Can someone who sees this issue make a small known-to-exhibit-the-issue file available for me to download to use for testing? (Ideally, transcode a recording to 30 seconds or so and verify that the result exhibits the issue.)

comment:5 Changed 10 years ago by sphery

Keywords: solid color RTJPEG NUV added
Resolution: invalid
Status: infoneeded_newclosed
Summary: No recording preview picture after transcodingSolid-color preview with RTJPEG in NUV recordings/transcodes

Closing this ticket as invalid--no response in 3 weeks. If anyone wants it fixed, they need to provide a clip of a recording that is known to exhibit the issue, as I can't reproduce the issue even after transcoding to RTJPEG in NUV. If you provide a sample, please reopen this ticket.

comment:6 Changed 10 years ago by Janne Grunau

(In [24126]) NVR: use correct type for lzo*compress dest_len parameter

might fix a stack corruption on 64bit Linux. Refs #8076

Note: See TracTickets for help on using tickets.