Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#8084 closed defect (duplicate)

Changeset 23503 in Trunk causes slowness in mythweb

Reported by: anonymous Owned by: xris
Priority: critical Milestone: 0.23
Component: Plugin - MythWeb Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Because every sendCommand() call in MythBackend?.php now also calls receiveData(1), there are many situations where receiveData is waiting on data which does not exist.

This introduces several seconds of delay when loading mythweb pages. In my environment, loading the listings page goes from from sub-1 second to almost 8.

Change History (5)

comment:1 Changed 9 years ago by Janne Grunau

Milestone: unknown0.23
Owner: changed from Rob Smith to xris
Priority: minorcritical
Status: newassigned
Version: unknownhead

introduced in [23503]

comment:2 Changed 9 years ago by David Kubicek <foceni@…>

I created ticket #8117 with a patch. Sorry, didn't notice this one.

comment:3 Changed 9 years ago by beirdo

Resolution: duplicate
Status: assignedclosed

Marked as duplicate of #8117

comment:4 Changed 9 years ago by cpinkham

(In [23636]) Allow the 'wants' events' field in the ANNounce string to specify whether a client wants to receive (0) no events, (1) all events, (2) non-system events, or (3) only system events.

This is the basis for a fix for issues encountered when MythWeb doesn't like receiving the "client connected" system event when MythWeb itself connects to the master backend.

Also modifies the Perl bindings to allow them to specify this value when connecting since I used the Perl bindings to help test this functionality.

References #8084, and #8117.

comment:5 Changed 9 years ago by cpinkham

(In [23637]) Modify MythWeb to use a new value for the ANNounce string wantsevents of '2' to indicate that MythWeb does not want to receive system events from the backend. This allows us to eliminate the 1-second delay that was recently inserted after MythWeb's connect which was setup to catch the new "client connected" system event. This does not fix cases where MythWeb might receive another backend message while it is connecting, that can only be fixed by a larger more invasive patch. This only fixes the recent issues reported after the system events patch whent into trunk.

References #8084 and Fixes #8117.

Note: See TracTickets for help on using tickets.