Opened 9 years ago

Closed 9 years ago

#8102 closed defect (invalid)

Mythgame settings are not saved per-frontend on single machine

Reported by: techiem2 Owned by: greg
Priority: minor Milestone: unknown
Component: Plugin - MythGame Version: 0.22
Severity: medium Keywords: mythgame settings
Cc: Ticket locked: no

Description

When a machine is setup with multiple frontends using the custom hostname setting to differentiate them, mythgame does not save the settings per frontend. The settings are applied to all frontends on the machine rather than just the frontend with the custom hostname that saved the settings.

Change History (3)

comment:1 Changed 9 years ago by robertm

Status: newinfoneeded_new

What settings? Most MythGame? settings are global.

comment:2 Changed 9 years ago by techiem2

Ok, I just checked the settings:

General Settings seem to be saved per frontend.

Game Players are saved globally at the backend level.

Thich is a problem for multiple frontends on that same machine that need different settings (i.e. different PC Games scripts locations or different ROM locations).

This is more of a problem for frontends running on other machines that are connecting to the master backend, as they may not have access to the paths set unless you store everything on a network mount and mount that location on every frontend that uses that backend. Other frontends may also not have all the same games/emulators installed for whatever reason (power, desired usage, etc.), and therefore would not be able to play the items in the list.

If this was the intended behavior when MythGame? was written, I guess this might more appropriately be a feature change request than a bug report (just depends on how you look at it).

It seems to me it would be more logical (and more flexible) to save the Game Player settings at the frontend level, since MythTV is designed to have multiple independent frontends on various machines all using the same backend.

comment:3 Changed 9 years ago by robertm

Resolution: invalid
Status: infoneeded_newclosed

This is as intended. I don't believe we would want to modify the existing behavior to have per-frontend game settings, either, as the idea is to make the libraries consistent across platforms.

Note: See TracTickets for help on using tickets.