Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#8108 closed defect (invalid)

dvd playback on via epia M10k causes mythfrontend or X to segfault

Reported by: cantoni.alessandro@… Owned by: skamithi
Priority: minor Milestone: unknown
Component: MythTV - DVD Playback Version: 0.22-fixes
Severity: medium Keywords: dvd playback epia
Cc: Ticket locked: no

Description

I'm experiencing this on two epia m10k boards. One mounts ubuntu 9.10 and mythfrontend branches/release-0-22-fixes (22594): it plays DVD intro and then causes mythfrontend to segfault without givin me any clue. The other mounts ubuntu 10.4 and mythfrontend 0-22-fixes (23193) and causes X to segfault in the same situation; on this second machine a look at Xorg log reveals this: "(EE) CHROME(0): [XvMC] ViaXvMCCreateSurface: Too many surfaces !" Googling a bit I found that something similar had previously been reported here: http://www.mythtv.org/pipermail/mythtv-users/2010-January/278065.html but it doesn't talk about dvd playback and the proposed fixes goes beyond my linux knowledge (and my little spare time). I'm quite sad because I finally managed to assemble two working frontends for my daughter and living room.... (as you can argue from the old hardware involved, it took me a lot of time :) Thank you in advance and bye, Alessandro (IT).

Change History (6)

comment:1 Changed 10 years ago by JYA

Resolution: invalid
Status: newclosed

X crashing isn't a mythtv bugs...

Please provide a backtrace (instructions are on the wiki)

comment:2 Changed 10 years ago by Stuart Auchterlonie

Milestone: unknown0.24
Resolution: invalid
Status: closednew

X crashing isn't a mythtv bug, but attempting to use more surfaces than are available is.

Stuart

comment:3 Changed 10 years ago by danielk

Resolution: invalid
Status: newclosed

Stuart, that's the API. You request surfaces until the driver says no or until you have enough (32) whichever comes sooner. We already have some hacks for this driver, but at this point it doesn't make sense to add more hacks for yet another regression in a driver for a dead platform.

comment:4 Changed 10 years ago by anonymous

First I'd like to thank you for your fast replyes. I've tryed to produce a backtrace following this howto: http://www.mythtv.org/wiki/Debugging section "debuggin with ubuntu packages", but playing dvds hangs the system and apparmor doesn't start at all. I've tryied to follow instructions given in the link on my first post (compiling without opengl and reducing max_surfaces to 14 or 12) without luck: live-tv works well as usual (about 25% cpu usage) but dvd playback with internal player still hangs "near" menus. I can try to investigate this issue a bit if you feel it's worth a try and if you can help me a bit, otherwise I'll convince myself to start ripping my dvds... If you feel it could be of any use I can try to ask openchrome team too. another way could be trying to use mplayer instead of internal player for dvd playback, but this will force me to learn how to patch mplayer to enable epia m mpeg2 acceleration... last: if you can point me to any link with some suggestion..... thank you for your work, and bye, Alessandro. P.S. epia m is obiouvsly a dead platform but I think nowaday it's a cheap mobo to create a mythtv frontend (since here in Italy we still use CRT and HD tv is far from beeing a standard...)

comment:5 Changed 10 years ago by stuartm

Milestone: 0.24unknown

comment:6 in reply to:  5 Changed 10 years ago by sameasabove

Minimal update:

  • Playing a DVD with Mplayer (without patch) or Gxine causes exactly the simptoms described into my first post... (myth/X segfault or system hang)
  • The worst is that using mythfrontend to play ripped DVDS (ripped at original pal res) results in the same bugs with simptoms occurring 5-10 minutes from video beginning....

Tx and bye, Alessandro.

Note: See TracTickets for help on using tickets.