Opened 14 years ago

Closed 14 years ago

#811 closed defect (fixed)

DVB recordings on one channel mangled

Reported by: stuart@… Owned by: danielk
Priority: minor Milestone: unknown
Component: dvb Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

A commit after 8239, I think, now causes recordings on at least one channel (More4 in the UK) to be entirely unwatchable. The video and audio jitter and stutter, the audio eventually ends up completely out of sync. The recordings also have corrupted seek tables in common with another recently introduced bug - but rebuilding the tables doesn't improve things.

The recordings play back fine in xine - so the problem isn't with recording just playback.

It might be relevant that they all had two audio tracks - the standard 2 channel and a second 1 channel audio-descriptive (for the blind).

I will provide logs if asked.

Change History (3)

comment:1 Changed 14 years ago by danielk

Milestone: unknown

Can you try reverting [8244], and see if that fixes playback?

comment:2 Changed 14 years ago by anonymous

Yup [8244] was the problem and from the commit list it seems the issue has already been fixed? (Sorry for the delay, was down the pub)

comment:3 Changed 14 years ago by anonymous

Resolution: fixed
Status: newclosed

Nothing wrong with spending some time at the pub. Most [8244] has been reverted, but you may want to reply to Mark Spieth's query in mythtv-dev since he wants to fix the problem with the rest of the code in [8244].

Note: See TracTickets for help on using tickets.