Opened 9 years ago

Closed 8 years ago

#8116 closed defect (fixed)

sound but no video

Reported by: anonymous Owned by: Janne Grunau
Priority: minor Milestone: 0.23-fixes
Component: MythTV - Video Playback Version: 0.22-fixes
Severity: medium Keywords:
Cc: Ticket locked: no

Description

I have "random" occurrences of sound but no video. When this happens the only fix is to logout and login, or reboot. After that everything is okay again. I get this when watching videos and recordings. Attached a full debug log when it is in this mode.

This error seems important:

X Error: BadValue? (integer parameter out of range for operation) 2

Extension: 132 (Uknown extension) Minor opcode: 19 (Unknown request) Resource id: 0x4000001

Using latest .22 fixes on Ubuntu 9.10

Attachments (5)

crash.log.gz (362.2 KB) - added by craig cook <cncook001@…> 9 years ago.
full debug log
Xorg.0.log.gz (6.6 KB) - added by craig cook <cncook001@…> 9 years ago.
playback.log.gz (5.4 KB) - added by craig cook <cncook001@…> 9 years ago.
playback2.log.gz (5.0 KB) - added by craig cook <cncook001@…> 9 years ago.
playback3.log.gz (5.0 KB) - added by craig cook <cncook001@…> 9 years ago.

Download all attachments as: .zip

Change History (32)

Changed 9 years ago by craig cook <cncook001@…>

Attachment: crash.log.gz added

full debug log

comment:1 Changed 9 years ago by danielk

Status: newinfoneeded_new

Does hitting 'w' make the video appear?

comment:2 Changed 9 years ago by craig cook <cncook001@…>

I will test that next time it happens. It may take a few weeks since this does not happen often.

comment:3 Changed 9 years ago by cncook001@…

Pressing W or w does not do anything. Sound but no video continues. Have to ESC out, logout and login again.

comment:4 Changed 9 years ago by stuartm

Milestone: unknown0.23
Status: infoneeded_newnew

comment:5 Changed 9 years ago by robertm

Status: newinfoneeded_new

This appears to be broken video drivers. What GPU and drvier are you using?

comment:6 Changed 9 years ago by danielk

Note: This could still be a MythTV bug, but we'd need a "mythfontend -v playback" log in addition to the info Robert asked for. X Errors can be caused by two threads attempting to use the same display connection at the same time, but we made a good deal of effort eliminating those bugs after the Qt4 port which changed some of the video playback threading.

Changed 9 years ago by craig cook <cncook001@…>

Attachment: Xorg.0.log.gz added

comment:7 Changed 9 years ago by craig cook <cncook001@…>

ati-driver-installer-9-11-x86.x86_64.run

(--) PCI:*(0:1:0:0) 1002:9540:174b:e970 ATI Technologies Inc RV710 [Radeon HD 4550] rev 0, Mem @ 0xd0000000/268435456, 0xfdbe0000/65536, I/O @ 0x0000ee00/256, BIOS @ 0x????????/131072

full X log attached. output from mythfrontend can be found in crash.log.gz

This error occurred with earlier ATI drivers as well. I will update to ATI 10.3 and see what happens. Myth is somehow exposing a bug. When in this condition mplayer will play video files fine, but myth will only give me sound.

comment:8 Changed 9 years ago by robertm

Craig,

Can you provide a frontend log with -v playback only? -v all is very hard to parse (not impossible, just not easy at a glance).

Changed 9 years ago by craig cook <cncook001@…>

Attachment: playback.log.gz added

comment:9 Changed 9 years ago by craig cook <cncook001@…>

updated to ati 10.3 driver but sound with no video happened again. new playback log attached

comment:10 Changed 9 years ago by robertm

Status: infoneeded_newnew

Craig,

Out of curiosity, what deinterlacer are you using? If not already doing so, try the "Slim" playback profile. If that doesn't work, try disabling deinterlacing altogether.

comment:11 Changed 9 years ago by robertm

Also, just for giggles, please try switching to a theme that is actually supported in .22, like Terra or Graphite, and see what happens.

comment:12 Changed 9 years ago by robertm

Component: MythTV - DVD PlaybackMythTV - Video Playback
Owner: changed from skamithi to Janne Grunau

comment:13 Changed 9 years ago by cncook001@…

Not sure, I will check tonight. It is the "High Quality" setting. I have a tri core AMD CPU so am not concerned with CPU usage. Will also change the theme.

I also have a possibly unrelated issue with zoom. With some programs I get corruption on the right hand side of the screen. A bunch of pixels stretched/blurred to the right, about where the black bars would be in 4:3 mode. It looks like someone took the very right edge and dragged it across the screen to the right. I have set playback to 16:19, with Zoom Auto Detect (default off). If I change Zoom Auto Detect to off, the corrupted side goes away and the image looks fine.

The other fix is to go to menu while in playing the program and change aspect ratio to 4:3, it then stretches correctly. Should I open a new case for this?

comment:14 Changed 9 years ago by craig cook <cncook001@…>

Changed to use terra and slim playback profile. Will see what happens.

Changed 9 years ago by craig cook <cncook001@…>

Attachment: playback2.log.gz added

Changed 9 years ago by craig cook <cncook001@…>

Attachment: playback3.log.gz added

comment:15 Changed 9 years ago by craig cook <cncook001@…>

playback2 is using terra and slim profile. playback3 shows deinterlacer set to none. I did not logout or reboot before creating playback3.log.

comment:16 Changed 9 years ago by craig cook <cncook001@…>

when this happens using terra theme we see the number 1 with a circle and hear sound, do not get a picture though

comment:17 Changed 9 years ago by Janne Grunau

Status: newinfoneeded_new

comment:18 Changed 9 years ago by craig cook <cncook001@…>

I do not have cairo-dock installed. I do have libcairo2 installed though. Since my last crash 2 weeks ago I have been using graphite and it has not crashed. Is there something different in the implementation to terra?

comment:19 Changed 9 years ago by craig cook <cncook001@…>

Posted too soon. It crashed today. I did note mythfrontend was using 1008m of memory before I rebooted. It now uses 834m.

comment:20 Changed 9 years ago by robertm

Status: infoneeded_newnew

comment:21 Changed 9 years ago by Stuart Auchterlonie

Milestone: 0.230.23-fixes

comment:22 Changed 9 years ago by craig cook <cncook001@…>

upgraded to ubuntu 10.04 and mythfrontend version: branches/release-0-23-fixes [24158] www.mythtv.org

sound and no video happened again. I did not capture logs this time. I will get playback logs next time it happens.

comment:23 Changed 8 years ago by anonymous

upgraded to release-0-23-fixes [25253]. also changed to slim profile. Has not crashed yet. Will see how it goes.

comment:24 Changed 8 years ago by robertm

Status: newinfoneeded_new

Need testing against trunk if still present in .23-fixes.

comment:25 Changed 8 years ago by robertm

Milestone: 0.23-fixesunknown

comment:26 Changed 8 years ago by anonymous

Please close this ticket. Since upgrading to .23 it has not crashed.

comment:27 Changed 8 years ago by stuartm

Milestone: unknown0.23-fixes
Resolution: fixed
Status: infoneeded_newclosed
Note: See TracTickets for help on using tickets.