Opened 9 years ago

Closed 8 years ago

#8144 closed defect (Fixed)

internal dvd player: another dvd fast playback problem

Reported by: skamithi Owned by: markk
Priority: minor Milestone: 0.25
Component: MythTV - DVD Playback Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

when watching a dvd in Picture by picture mode, and placing the dvd video on the side with no audio, the dvd plays at about 2 times the normal speed. Swapping it back to be the active video, makes the speed go well. This doesn't affect all dvds, just some.

Found out the problem is that the normalized_fps function in AVFormatdecoder is returning the wrong fps value initially. Even when, later during the stream, it changes to the correct fps, the dvd speed is still fast.

patch attached is a workaround until I can figure out why normalized_fps function is doing this. in the patch, the dvd fps is obtained from the dvd IFO instead of from normalized_fps function. I would like to get normalized_fps function to do the right thing instead of using this workaround.

Attachments (1)

initial_fps_incorrect.patch (602 bytes) - added by skamithi 9 years ago.

Download all attachments as: .zip

Change History (6)

Changed 9 years ago by skamithi

Attachment: initial_fps_incorrect.patch added

comment:1 Changed 9 years ago by robertm

Component: MythTV - GeneralMythTV - DVD Playback

comment:2 Changed 9 years ago by robertm

Milestone: 0.24unknown

comment:3 Changed 9 years ago by robertm

Status: newassigned

comment:4 Changed 8 years ago by beirdo

Owner: changed from skamithi to markk

comment:5 Changed 8 years ago by markk

Milestone: unknown0.25
Resolution: Fixed
Status: assignedclosed

This is almost certainly fixed in master due to all the dvd startup improvements - though impossible to verify as dvd PBP is currently broken.

Note: See TracTickets for help on using tickets.