Opened 10 years ago

Closed 10 years ago

#8171 closed enhancement (duplicate)

mythicalLibrarian user contribution

Reported by: outleradam@… Owned by: sphery
Priority: minor Milestone: 0.23
Component: Contributed Scripts & Apps Version: head
Severity: low Keywords:
Cc: Ticket locked: no

Description

I am finished with the core features of mythicalLibrarian, a script to rename mythtv recordings into season and episode. I was wondering if this would be good to add in as a contribution?

Basically, the way I think of mythicalLibrarian is all in the name. It determines if the movie is an episode, show, or movie.

Movies are referenced against the mythtvdb, and assigned Title (year).ext Shows are assigned a Title S0E0 (subtitle).ext name

Episodes are referenced against the mythtvdb, thetvdb.com and assigned a Title SxxExx? (subtitle).ext. mythicalLibrarian works offline and has a multitude of safety checks to ensure proper naming including:

--doover feature which repeats any episodes which were assigned to the doover que because the internal logic determined information was not availble at the time from thetvdb.

--undo feature which removes all changes --scan which allows the user to scan a whole folder for a speciffic type of file and then process each one through mythicalLibrarian

This program is constantly adapting to new guide data types, so any problem reports which are filed can be addressed and once fixed, the user can run mythicalLibrarian --update and grab the latest version.

I have spent months of work on this and it is my goal to fully support every show in the best possible manner with absolutely zero human intervention. This is why I call it mythicalLibrarian. It is a librarian who works to keep your files not only human readable, but all information which is known may be rebuilt after a full database crash by using the naming conventions which I have set.

Change History (1)

comment:1 Changed 10 years ago by robertm

Resolution: duplicate
Status: newclosed

Dupe of #8170

Note: See TracTickets for help on using tickets.