Opened 9 years ago

Closed 9 years ago

#8181 closed defect (duplicate)

Mythmusic CD playback stops and starts every 15 seconds

Reported by: psylencer <d.herlihy@…> Owned by: Isaac Richards
Priority: trivial Milestone: unknown
Component: Plugin - MythMusic Version: head
Severity: low Keywords: Mythmusic CD Playback 15 seconds
Cc: Ticket locked: no

Description

I've read all the forum posts in relation to this issue without any luck what so ever.

Here's what happens :

Open mythmusic Play a CD CDROM drive reads for about 5 seconds then stops playback gets to about 15 seconds then stops for about 3 seconds CDROM drive then starts reading again, Music starts to play again. Music stops, REPEAT

This happens every 15 seconds or so.

I have , have tested a variety of audio setups, Nothing changes.

Can I make very clear than DVD Playback is fine. Music playback from the HDD is fine if I have ripped the music, infact everything else is absolutely wonderful.

Please don't respond with "this has been fixed in trunk..." . Whatever has been fixed has been completely unfixed.

I have also tried the following to no avail :

sudo hdparm -a 2048 devsr0 <--yes I have the drive correct. This has been verified.

I have absolutely no problems playing back CDs in other audio apps like VLC <-which is what i used to verify the mount location.

I have no buffer underrun messages in my mythfrontend log.

I have tried a variety of CDs all of which display the same problem.

Here is some version information :

apt-cache policy mythmusic

mythmusic:

Installed: 0.23.0~trunk23738-0ubuntu0~mythbuntu1 Candidate: 0.23.0~trunk23738-0ubuntu0~mythbuntu1 Version table:

* 0.23.0~trunk23738-0ubuntu0~mythbuntu1 0

500 http://us.autobuilds.mythbuntu.org karmic/main Packages 100 /var/lib/dpkg/status

0.22.0+fixes22594-0ubuntu1 0

500 http://au.archive.ubuntu.com karmic/multiverse Packages

I've seen a few posts in regards to this issue, however they have all been relevant to older versions and been closed.

Hopefully someone can shed some light on this.

Kind Regads Dan

Change History (6)

comment:1 Changed 9 years ago by paul@…

do you see anything in the frontend.log

see ticket : http://svn.mythtv.org/trac/ticket/7784

comment:2 Changed 9 years ago by psylencer <d.herlihy@…>

mythfrontend.log displays absolutely nothing after :

2010-03-15 23:45:40.257 CD status has changed.
2010-03-15 23:45:47.245 Opening audio device '/dev/dsp'. ch 2(2) sr 44100 (reenc 0)
2010-03-15 23:45:47.245 Opening OSS audio device '/dev/dsp'.

Incidentally, I changed the DVD drive from a (brand new) LG G22NS50 (drive with problem) to a (much older) Pioneer DVR-215BK and the problem disappeared.

I'd keep the Pioneer drive in, but it's way too noisy.

Again, DVD playback with the LG works fine in mythTV and CD playback works fine in VLC with the LG drive.

Im thinking the problem may have something to do with a "feature" or lack thereof of either the LG or Pioneer drive and the way mythmusic communicates with it. My immediate thoughts are buffer problems but no clues given in mythfrontend.log.

Regards Dan

comment:3 Changed 9 years ago by robertm

Milestone: 0.23unknown
Priority: majortrivial
Severity: highlow
Version: 0.22-fixeshead

Read the ticket howto, do not set milestones, severities, or priorities on tickets.

comment:4 Changed 9 years ago by stuartm

Resolution: worksforme
Status: newclosed

Dan, I'm marking this as a duplicate of #7784, could you attach a logs using '-v media' when using the drive that doesn't work. It might be interesting to see the log with the working drive if there is a difference.

comment:5 Changed 9 years ago by stuartm

Resolution: worksforme
Status: closednew

comment:6 Changed 9 years ago by stuartm

Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.