Opened 10 years ago

Closed 9 years ago

#8188 closed patch (Won't Fix)

Truncated translate in MythCenter and MythCenter-wide

Reported by: Choteau <gillessoixantequatorze@…> Owned by: danielk
Priority: trivial Milestone: 0.25
Component: Themes Version: unknown
Severity: low Keywords:
Cc: Ticket locked: no

Description

I verify the french translation in the context and i find that many texts are cut, i give you 2 exemples

1) when you are in the program guide and you choice your next recording.

you define the rule ==> Record at any time on any channel (in french, Enregistrer à n'importe quel moment sur n'importe quelle chaîne) the text is truncated like this

in Mythcenter ==> Enregistrer à n'importe quel moment sur n'impor...

2) in the same condition you verify dups in the last recording. the text is truncated like this

in Mythcenter ==> Rechercher les doublons dans les enregistrem..

And for "Look for duplicates in current and previous recordings" it's the same text. In this case it impossible to make the difference.

My screen is in 1024x576 and i try to adjust the font size but it's not enough (-30% max)and it applied for all text. This screen is enough to increase the buttonlist and so on.

This patch add same extralarge wigdet to use the free space and change the position.

4 windows are changed sheduleeditor scheduleoptionseditor storageoptionseditor postproceditor

I make the same job for Terra and Arclight

Attachments (11)

mythcenter.diff.tar.bz2 (3.2 KB) - added by Choteau <gillessoixantequatorze@…> 10 years ago.
patch for MythCenter? and MythCenter?-wide
mythcenter.diff.tar.2.bz2 (3.3 KB) - added by Choteau <gillessoixantequatorze@…> 10 years ago.
news unified patch for Mythcenter et Mythcenter-wide
mythcenter1.diff (66.2 KB) - added by Choteau <gillessoixantequatorze@…> 10 years ago.
a new version available for all the mythcenter(wide) theme
mythcenter2.diff (64.9 KB) - added by Choteau <gillessoixantequatorze@…> 10 years ago.
good form (sorry it's my first patch)
mythcenter3.diff (64.9 KB) - added by Choteau <gillessoixantequatorze@…> 10 years ago.
change low>Low high>High (mistake) in mythweather
mythcenter4.diff.tar.bz2 (13.0 KB) - added by Choteau <gillessoixantequatorze@…> 10 years ago.
another correction in System Events Handler
mythcenter5.diff.tar.bz2 (11.6 KB) - added by Choteau <gillessoixantequatorze@…> 10 years ago.
a small modification and delete bad diff
mythcenter6.tar.bz2 (29.0 KB) - added by gillessoixantequatorze@… 9 years ago.
Update patch
mythcenter7.diff (9.9 KB) - added by gillessoixantequatorze@… 9 years ago.
rebuilt edit_metadata page
mythcenter8.diff (44.8 KB) - added by gillessoixantequatorze@… 9 years ago.
revisit the manage_recording page and increase the selected item
mythcenter9.diff (40.8 KB) - added by gillessoixantequatorze@… 9 years ago.
new patch (replace old )

Download all attachments as: .zip

Change History (27)

Changed 10 years ago by Choteau <gillessoixantequatorze@…>

Attachment: mythcenter.diff.tar.bz2 added

patch for MythCenter? and MythCenter?-wide

Changed 10 years ago by Choteau <gillessoixantequatorze@…>

Attachment: mythcenter.diff.tar.2.bz2 added

news unified patch for Mythcenter et Mythcenter-wide

comment:1 Changed 10 years ago by robertm

Milestone: 0.23unknown
Priority: minortrivial
Severity: mediumlow

Please read the ticket howto, don't set milestones on tickets.

Changed 10 years ago by Choteau <gillessoixantequatorze@…>

Attachment: mythcenter1.diff added

a new version available for all the mythcenter(wide) theme

comment:2 Changed 10 years ago by Choteau <gillessoixantequatorze@…>

this patch modify 10 screens; same changes are in menu and menu-wide and I make the validation for Terra impact. All are OK and in english language also.

comment:3 Changed 10 years ago by robertm

Status: newinfoneeded_new

Gilles,

These diffs aren't made against myth source, which makes them really hard to apply-- they're made against the installed directories. The plugin -ui files are in mythplugins/$Pluginname/theme/default and default-wide. You should check out the source with svn, make your changes on the original files, and then use the "svn diff" command from the root of your source directory so that you produce a diff that is appliable. As it is right now, these would need to be applied one by one, manually.

Changed 10 years ago by Choteau <gillessoixantequatorze@…>

Attachment: mythcenter2.diff added

good form (sorry it's my first patch)

comment:4 Changed 10 years ago by Choteau <gillessoixantequatorze@…>

I don't find the solution for 3 problems existing before patching

1) in Mythvideo, menu"M", setting, the wigdet appear over the existing view (not creating a new window). this problem don't appear if you use the way settings, setting video, setting playersetting

2) in the screen setting, setting video, setting playersettings, if the text for the player command is too big, the text is write over the label (align right)

3) in the music metadata,if the title text is to long, a scroll box appear and the text disappear

Changed 10 years ago by Choteau <gillessoixantequatorze@…>

Attachment: mythcenter3.diff added

change low>Low high>High (mistake) in mythweather

comment:5 Changed 10 years ago by robertm

Status: infoneeded_newnew

Changed 10 years ago by Choteau <gillessoixantequatorze@…>

Attachment: mythcenter4.diff.tar.bz2 added

another correction in System Events Handler

Changed 10 years ago by Choteau <gillessoixantequatorze@…>

Attachment: mythcenter5.diff.tar.bz2 added

a small modification and delete bad diff

comment:6 Changed 9 years ago by danielk

Owner: changed from Isaac Richards to danielk
Status: newassigned

comment:7 Changed 9 years ago by danielk

Milestone: unknown0.24

comment:8 Changed 9 years ago by danielk

The settings-ui.xml changes allow descriptive text to overlap the text entry field.

comment:9 Changed 9 years ago by danielk

(In [26276]) Refs #8188. Apply MythCenter?-wide portion of #8188, expanding some text areas to allow for translation. This does not apply any of the plugin changes in the patch nor the non-wide portions.

comment:10 Changed 9 years ago by danielk

Milestone: 0.24unknown
Status: assignedinfoneeded

There are a number of odd numbered positions in the plug-in portion of this patch and some of it doesn't apply anymore. Can you update the patch against current trunk and make sure all positions and sizes are even numbers? Even numbers are required so that it looks similar on both 1280x720 and 1920x1080 screens.

Changed 9 years ago by gillessoixantequatorze@…

Attachment: mythcenter6.tar.bz2 added

Update patch

comment:11 Changed 9 years ago by gillessoixantequatorze@…

I add in the update patch a new file for the active background button. Put button_on.png in mythtv/themes/MythCenter-wide/ui to try

Changed 9 years ago by gillessoixantequatorze@…

Attachment: mythcenter7.diff added

rebuilt edit_metadata page

Changed 9 years ago by gillessoixantequatorze@…

Attachment: mythcenter8.diff added

revisit the manage_recording page and increase the selected item

comment:12 Changed 9 years ago by danielk

Milestone: unknown0.24
Status: infoneededassigned

comment:13 Changed 9 years ago by danielk

Status: assignedinfoneeded

I'm still getting a bunch of rejects and this is patching things outside of MythCenter?-wide.

Please put only MythCenter?-wide things in the patch. If you need to modify the default theme to get an effect in MythCenter?-wide, please copy that xml file into the MythCenter?-wide theme and apply the change there.

Also, please do not create overlapping patches. If there is an overlap create a new patch that replaces all previous patches and note this in the description.

comment:14 Changed 9 years ago by gillessoixantequatorze@…

Think to see my work and sorry for my bad english and for patch's rejets, i attach the new patch

I try to find good way to see complete texte in all language with resolution 800x600, 1280x720 and more. Inside this patch, you can find many parts, same modifications are trivial (for me) or not, one introduce new design of page with new words et one change the look of the page and need you approbation. Because the problem isn't only for MythCenter?-Wide inside you find same parts for all wide themes

1) in defaut-wide/netvision_ui, i increase the "search" expression area et move the button. this is trivial and available for the wide theme

2) in defaut-wide/mythvideo_ui (itemdetailpopup), i propose to use the "rating" area for cast, this area is multiline it's necessary for cast not for rating. I move "rating" at the end of director line. I verify it's applied for all themes . This modification is in defaut wide and also in mythcenter-wide.

3) in defaut-wide/mythvideo_ui (meatdatasettings, playersettings, file_associations) : trivail for me, change the width of many areas in video_settings pages. Those modifications are in defaut-wide and also in the mythcenter-wide

4) in mythcenter_wide/video_ui; rebuilt the edit_metadata page with new textes

5) in mythcenter_wide/schedule_ui: I revisite this page and add an extra large area for the active position. This change the look and i am sure it's not good because in this case, we can have a very big green active area with a small text. It's possible to reduce this effect with the gradient or with a new background picture

I needs your feeling for all this modifications before to make more. I prefer change the theme inside mythtv but if it's too difficult, i can create a new theme

Changed 9 years ago by gillessoixantequatorze@…

Attachment: mythcenter9.diff added

new patch (replace old )

comment:15 Changed 9 years ago by robertm

Milestone: 0.240.25

This patch is a long way from being appliable, has some formatting issues, and (IMO) is too many things changing all at once. Bumping to .25.

comment:16 Changed 9 years ago by robertm

Resolution: Won't Fix
Status: infoneededclosed

This patch isn't acceptable. It changes tons and tons in default and specific themes, and in ways that break formatting and visual flow. It's just unappliable as it is. Please feel free to break adjustments to each theme out into seperate patches, and *please* watch the formatting, indentation, and extra spaces. This ticket isn't getting any closer to being appliable, so I'm closing it.

Note: See TracTickets for help on using tickets.