Opened 10 years ago

Closed 10 years ago

#8189 closed defect (fixed)

Crash on large screen

Reported by: mvanross@… Owned by: JYA
Priority: minor Milestone: unknown
Component: MythTV - General Version: unknown
Severity: medium Keywords:
Cc: Ticket locked: no

Description (last modified by Dibblah)

Hi

I'm running mythtv windowed on a hires (2560x1660 screen). This gives a segmentation fault. Ok on lower resolution screeens.

mythfrontend -geometry 600x400 -w
2010-03-16 11:24:27.946 mythfrontend version: tags/release-0-22 [0.22] www.mythtv.org
2010-03-16 11:24:27.968 AudioPulseUtil: Suspend Success
2010-03-16 11:24:27.968 Overriding GUI size: width=600 height=400
2010-03-16 11:24:27.969 Using runtime prefix = /usr
2010-03-16 11:24:27.969 Using configuration directory = /home/vrossum/.mythtv
2010-03-16 11:24:28.541 Empty LocalHostName.
2010-03-16 11:24:28.541 Using localhost value of t61p
2010-03-16 11:24:28.551 New DB connection, total: 1
2010-03-16 11:24:28.554 Connected to database 'mythconverg' at host: localhost
2010-03-16 11:24:28.554 Closing DB connection named 'DBManager0'
2010-03-16 11:24:28.596 ScreenSaverX11Private: Gnome screen saver support enabled
2010-03-16 11:24:28.597 DPMS is active.
2010-03-16 11:24:28.598 Primary screen: 0.
2010-03-16 11:24:28.599 Connected to database 'mythconverg' at host: localhost
2010-03-16 11:24:28.601 Using screen 0, 2560x1600 at 0,0
2010-03-16 11:24:28.621 MythUI Image Cache size set to 20971520 bytes
2010-03-16 11:24:28.621 Setting 'RunFrontendInWindow' being forced to '1'
2010-03-16 11:24:28.622 Enabled verbose msgs:  important general
2010-03-16 11:24:28.626 Primary screen: 0.
2010-03-16 11:24:28.627 Running in a window
2010-03-16 11:24:28.627 Using screen 0, 2560x1543 at 0,0
2010-03-16 11:24:28.627 Using theme base resolution of 1280x720
2010-03-16 11:24:28.632 LIRC, Error: Failed to connect to Unix socket '/var/run/lirc/lircd'
                        eno: No such file or directory (2)
2010-03-16 11:24:28.632 JoystickMenuThread Error: Joystick disabled - Failed to read /home/vrossum/.mythtv/joystickmenurc
2010-03-16 11:24:28.663 Using the Qt painter
QImage::scaled: Image is a null image
QImage::scaled: Image is a null image
QImage::scaled: Image is a null image
2010-03-16 11:24:28.891 Loaded base theme from /usr/share/mythtv/themes/Terra/base.xml
QImage::scaled: Image is a null image
2010-03-16 11:24:28.924 Loaded base theme from /usr/share/mythtv/themes/default-wide/base.xml
2010-03-16 11:24:28.942 Loaded base theme from /usr/share/mythtv/themes/default/base.xml
2010-03-16 11:24:28.945 Current MythTV Schema Version (DBSchemaVer): 1244
2010-03-16 11:24:29.103 Desktop video mode: 2560x1600 60.0024 Hz
Segmentation fault

Attachments (1)

gdb.txt (45.6 KB) - added by mvanross@… 10 years ago.

Download all attachments as: .zip

Change History (12)

comment:1 Changed 10 years ago by Dibblah

Description: modified (diff)
Status: newinfoneeded_new

Backtrace as described in the ticket howto, please.

Changed 10 years ago by mvanross@…

Attachment: gdb.txt added

comment:2 Changed 10 years ago by mvanross@…

Note suspicious floating points numbers at the end of the file.

This is on a Laptop+dell30in monitor setup. The display is cloned at 2560x1600 using the nvidia-settings tool

comment:3 Changed 10 years ago by mvanross@…

I need to update this. I think the resolution is not the problem, but the cloning of the screens confuses mythtv.

Now I also see crashes in lower resolutions, but only in the display clone mode.

comment:4 Changed 10 years ago by robertm

Status: infoneeded_newnew

Segfault seems to be in the nvidia refresh rate stuff.

comment:5 Changed 10 years ago by robertm

Owner: changed from Isaac Richards to JYA
Status: newassigned

comment:6 Changed 10 years ago by JYA

Status: assignedaccepted

Could you install the debugging symbols and provide a backtrace again?

Thanks

comment:7 Changed 10 years ago by JYA

Status: acceptedinfoneeded

comment:8 Changed 10 years ago by JYA

Resolution: fixed
Status: infoneededclosed

(In [24077]) In GetNvidiaRates?, test all values returned when calling libnvctrl. I'm hoping this would fix #8189, but I can't confirm as I can not reproduce the problem.

comment:9 Changed 10 years ago by JYA

Resolution: fixed
Status: closednew

Trac closes the bug automatically ...

comment:10 Changed 10 years ago by robertm

Status: newinfoneeded_new

mvanross,

Can you test with trunk to see if this has fixed your issue? Anything later than r24077 should be good to test. You could also potentially apply the changeset to .23-fixes.

comment:11 Changed 10 years ago by JYA

Resolution: fixed
Status: infoneeded_newclosed

Assume as fixed as no news for over 3 months r24077 was bacported to 0.23-fixes r25187

Note: See TracTickets for help on using tickets.