Opened 14 years ago

Closed 14 years ago

#819 closed defect (fixed)

DVB Channel Scan fails

Reported by: stuart@… Owned by: danielk
Priority: minor Milestone: 0.19
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

The channel scanner no longer works in current SVN. In particular the scan of existing transports complains "Timeout Scanning Transport ID xxxx -- no tables". Where xxxx is a valid transport ID of course.

It only manages to scan one transport (12290) correctly and only during a full scan of existing transports, never when scanned specifically.

Change History (3)

comment:1 Changed 14 years ago by danielk

Milestone: 0.19
Status: newassigned
Summary: DVD Channel Scan failsDVB Channel Scan fails

It looks like the timeouts are not being reset in a single transport scan; will fix.

For the scan of all transports, I can not reproduce. Can you try increasing the timeouts? These are only set to sane initial values when you create a new card entry.

comment:2 Changed 14 years ago by anonymous

I had already increased them to 10 seconds when I last had trouble with the scanner, but going to 20 seconds on the tuning timeout worked this time. It seemed to take all of those 20 seconds too.

The option to ignore the signal timeout was added because of the issue with my card. I presume something has changed since then to make it take even longer?

comment:3 Changed 14 years ago by danielk

Resolution: fixed
Status: assignedclosed

(In [8292]) Fixes #819.

Note: See TracTickets for help on using tickets.