Opened 9 years ago

Closed 9 years ago

#8204 closed defect (Works for me)

mythcommflag crash with CommDetector2 in the end of program

Reported by: otto at kolsi dot fi Owned by: cpinkham
Priority: minor Milestone: unknown
Component: MythTV - Mythcommflag Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

CommDetector2 is crashing repeatedly for some programs while for others it works fine. Crash seems to occur always in the end of the program/flagging.

I've attached backtrace and screen output from one the crashes. Standard CommDetector? works fine for this particular program.

I'm not sure if this is dup of #7893 (it looks like different problem).

$ mythbackend --version
Please include all output in bug reports.
MythTV Version   : 23768M
MythTV Branch    : trunk
Network Protocol : 56
Library API      : 0.23.20100314-1
QT Version       : 4.6.2
Options compiled in:
 linux debug silent using_oss using_alsa using_pulse using_pulseoutput using_backend using_dvb using_frontend using_lirc using_opengl_video using_opengl_vsync using_qtdbus using_qtwebkit using_x11 using_xrandr using_xv using_bindings_perl using_bindings_python using_opengl using_ffmpeg_threads

Attachments (2)

mythcommflag-gdb-bactrace.txt (18.7 KB) - added by otto at kolsi dot fi 9 years ago.
mythcommflag-gdb-screen-log.txt (21.9 KB) - added by otto at kolsi dot fi 9 years ago.

Download all attachments as: .zip

Change History (5)

Changed 9 years ago by otto at kolsi dot fi

Changed 9 years ago by otto at kolsi dot fi

comment:1 Changed 9 years ago by robertm

Status: newassigned

comment:2 Changed 9 years ago by cpinkham

Status: assignedinfoneeded

This error is occurring inside libav*, can you please try to reproduce with current trunk head? We just had another ffmpeg resync a week or two ago and have had at least one other since the initial bug report.

comment:3 Changed 9 years ago by cpinkham

Resolution: Works for me
Status: infoneededclosed

Closing this since it was probably fixed by one of the previous two libav* resyncs. If it is still reproducable with current trunk, the ticket can be reopened.

Note: See TracTickets for help on using tickets.