Modify

Opened 8 years ago

Closed 7 years ago

#8215 closed defect (invalid)

MythWeb hostname/setting hostname comparison is not case-insensitive

Reported by: anonymous Owned by: kormoc
Priority: minor Milestone: unknown
Component: Plugin - MythWeb Version: head
Severity: low Keywords:
Cc: Ticket locked: no

Description

I recently rebuilt my mythtv box. I manually backed up and restored the database. I accidentally changed the host name from 'HTPC' to 'htpc'. This caused some minor issues with old recordings that still had the old hostname in the database. But hostnames are suppose to be case-insensitive. So 'HTPC' & 'htpc' should be the same.

This failure should be rare. But it was hard to diagnose because I didn't really change the hostname.

Attachments (0)

Change History (10)

comment:1 Changed 8 years ago by ryan.goat@…

Not reported by anonymous. Reported by me.

comment:2 Changed 8 years ago by Dibblah

  • Resolution set to invalid
  • Status changed from new to closed

I am closing this as a feature request. If you come up with a patch, please comment on this ticket and it will be reopened.

comment:3 follow-up: Changed 8 years ago by robertm

  • Resolution invalid deleted
  • Status changed from closed to new

Ryan,

can you be more specific about what the minor issues *were*? It would help a lot to narrow down where this issue lives...

comment:4 Changed 8 years ago by robertm

  • Status changed from new to infoneeded_new

comment:5 in reply to: ↑ 3 Changed 8 years ago by ryan.goat@…

The failure I experienced was in mythweb. Mythweb failed to generate preview images on the "Recorded Programs" page for recordings with the old (all-caps) host name.

comment:6 Changed 8 years ago by robertm

Is the only issue in Mythweb?

comment:7 Changed 8 years ago by ryan.goat@…

That is the only verified error I found before I found the root cause and fixed the database entires.

I did not notice any related errors in mythfrontend. The old recordings played and generated preview pictures just fine. But I did not do a systematic search looking for errors.

comment:8 Changed 8 years ago by robertm

  • Component changed from MythTV - General to Plugin - MythWeb
  • Owner changed from ijr to kormoc
  • Status changed from infoneeded_new to new
  • Summary changed from Myth should interprate hostnames case-insensitivly to MythWeb hostname/setting hostname comparison is not case-insensitive

comment:9 Changed 8 years ago by beirdo

See also #6700

comment:10 Changed 7 years ago by kormoc

  • Resolution set to invalid
  • Status changed from new to closed

We control this via the database:

mysql> SELECT DISTINCT hostname FROM settings\G
*************************** 1. row ***************************
hostname: jessica

mysql> SELECT COUNT(0) FROM settings WHERE hostname = 'JESSICA'\G
*************************** 1. row ***************************
COUNT(0): 340

mysql> SELECT COUNT(0) FROM settings WHERE hostname = 'JeSsIcA'\G
*************************** 1. row ***************************
COUNT(0): 340

So in short, fix the database and all should be wel.

Add Comment

Modify Ticket

Action
as closed The owner will remain kormoc.
The resolution will be deleted. Next status will be 'new'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.