Opened 9 years ago

Closed 9 years ago

#8227 closed defect (invalid)

0.22 G3 iBook+Linux Build Fails

Reported by: mpapet@… Owned by: stuartm
Priority: minor Milestone: unknown
Component: MythTV - Mythfilldatabase Version: 0.22-fixes
Severity: high Keywords:
Cc: Ticket locked: no

Description (last modified by paulh)

Hi,

On a Debian Lenny installation, Mythtv build fails at Mythfilldatabase. I built the whole thing, but the idea was to just use the front end. I downloaded sources from the links on the front page of the site.

./configure --prefix=/usr --tune=G3  --enable-gpl --arch=ppc

cd mythfilldatabase/ && /usr/bin/qmake mythfilldatabase.pro -unix QMAKE=/usr/bin/qmake -o Makefile
cd mythfilldatabase/ && make -f Makefile
make[2]: Entering directory `/home/mpapet/mythtv-0.22/programs/mythfilldatabase'
ccache g++ -c -pipe -mtune=750 -mpowerpc-gfxopt -fomit-frame-pointer -O3 -maltivec -mabi=altivec -Wall -Wno-switch -Wpointer-arith -Wredundant-decls -Wno-non-virtual-dtor -funit-at-a-time -D__STDC_CONSTANT_MACROS -I/usr/include/directfb -D_REENTRANT -D_REENTRANT -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -DQT_NO_DEBUG -DQT_SQL_LIB -DQT_XML_LIB -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB -DQT_SHARED -I/usr/share/qt4/mkspecs/linux-g++ -I. -I/usr/include/qt4/QtCore -I/usr/include/qt4/QtCore -I/usr/include/qt4/QtNetwork -I/usr/include/qt4/QtNetwork -I/usr/include/qt4/QtGui -I/usr/include/qt4/QtGui -I/usr/include/qt4/QtXml -I/usr/include/qt4/QtXml -I/usr/include/qt4/QtSql -I/usr/include/qt4/QtSql -I/usr/include/qt4 -I/usr/include -I/usr -I../.. -I../../libs -I../../libs/libmyth -I../../libs/libmythtv -I../../libs/libavutil -I../../libs/libavformat -I../../libs/libavcodec -I../../libs/libmythupnp -I../../libs/libmythui -I../../libs/libmythlivemedia -I../../libs/libmythdb -I../../libmythhdhomerun -I../../libs/libmythdvdnav -I../../libs/libmythtv/mpeg -I/usr/X11R6/include -I. -I. -o filldata.o filldata.cpp
filldata.cpp: In member function ‘bool FillData::Run(SourceList&)’:
filldata.cpp:1057: internal compiler error: Segmentation fault
Please submit a full bug report,
with preprocessed source if appropriate.
See <file:///usr/share/doc/gcc-4.3/README.Bugs> for instructions.
make[2]: *** [filldata.o] Error 1
make[2]: Leaving directory `/home/mpapet/mythtv-0.22/programs/mythfilldatabase'
make[1]: *** [sub-mythfilldatabase-make_default] Error 2
make[1]: Leaving directory `/home/mpapet/mythtv-0.22/programs'
make: *** [sub-programs-make_default-ordered] Error 2

Let me know if you need anything else.

mpapet AT yAh00.com

Change History (3)

comment:1 Changed 9 years ago by mpapet@…

# Basic Settings Compile type release Compiler cache yes DistCC no qmake /usr/bin/qmake install prefix /usr runtime prefix /usr CPU ppc (ppc) big-endian yes runtime cpu detection no AltiVec? enabled no PPC 4xx optimizations no dcbzl available yes performance report no

# Input Support Joystick menu yes lirc support yes Video4Linux sup. yes ivtv support yes HD-PVR support yes FireWire? support yes DVB support yes usr/include DVB-S2 support no HDHomeRun support yes IPTV support yes

# Sound Output Support PulseAudio? support yes OSS support yes ALSA support yes aRts support no JACK support yes libfftw3 support no

# Video Output Support x11 support yes xrandr support yes xv support yes XvMC support yes XvMC VLD support yes XvMC pro support no XvMC libs -lXvMCW VDPAU support no OpenGL video yes OpenGL vsync yes DirectFB yes Fribidi formatting no MHEG support yes

# Misc Features multi threaded libavcodec yes Frontend yes Backend yes

# Bindings bindings_perl yes bindings_python yes

Creating libs/libmythdb/mythconfig.h and libs/libmythdb/mythconfig.mak

comment:2 Changed 9 years ago by paulh

Description: modified (diff)

comment:3 Changed 9 years ago by paulh

Resolution: invalid
Status: newclosed

filldata.cpp: In member function ‘bool FillData::Run(SourceList?&)’: filldata.cpp:1057: internal compiler error: Segmentation fault Please submit a full bug report, with preprocessed source if appropriate. See <file:///usr/share/doc/gcc-4.3/README.Bugs> for instructions. make[2]: * [filldata.o] Error 1

That's not a bug in MythTV. It's either a bug in the compiler you are using or often it's caused by an over heating processor/memory/chipset or bad memory. If you can repeat it and it crashes in the same place then it's likely a bug in the compiler. If you repeat it and it crashes in a different place then it's likely over heating or memory problems.

Note: See TracTickets for help on using tickets.