Opened 10 years ago

Last modified 4 years ago

#8272 infoneeded_new Bug Report - General

Satellite switching with DiseqC dosn't work sometimes

Reported by: David Dreschner <d4d4online@…> Owned by:
Priority: minor Milestone: unknown
Component: MythTV - DVB Version: Master Head
Severity: medium Keywords: diseqc
Cc: Ticket locked: no

Description

I use the current version of 0.23 from subversion with a TechnoTrend? S2-1600 satellite card and 2 satellites via a Spaun Multiswitch.

But i have a big problem. Sometimes, the switching to the second satellite via DiseqC won't work. This is especially bad when a scheduled recording, cause it can't record. The only solution is to delete the recording and switch a few times between different programms on the second satellite. This problem occurs not only by planed records, it occours on live-tv, too.

Attachments (1)

mythbackend.zip (314.9 KB) - added by David Dreschner <d4d4online@…> 10 years ago.
Mythbackend.log with verbose-option "all,nodatabase" and failed satellite-switching with DiseqC

Download all attachments as: .zip

Change History (9)

comment:1 Changed 10 years ago by robertm

Milestone: 0.23unknown
Priority: majorminor
Status: newinfoneeded_new

Read the tickethowto please, do not set milestones or priorities. We need verbose backend logs to do anything with this.

comment:2 Changed 10 years ago by David Dreschner <d4d4online@…>

Ohh, sorry for doing that. I though that i must set the milestone... Thanks for information!

Now, i've started the backend with '--verbose "all"' and switched the satellite for several times. The channel switching is now slower, and it seems to be solved. The DiseqC switching was always successfull - but only with the slower backend. Could it be that mythtv is to fast with the channel switching outside the verbose mode, so that the multiswitch hasn't done the satellite switch?

I've attached the mythbackend.log with the --verbose-option for several information.

comment:3 Changed 10 years ago by David Dreschner <d4d4online@…>

Okay, i've set the verbose-option to "all,nodatabase" (the file was easily to big ;) ) and the switching was failed once more. The frontend is showing the last picture from the channel i've watched before and the osd is showing "Signal 70% | Bitfehler 65535 | (l) Kein Lock"

I've attached the mythbackend.log.

Changed 10 years ago by David Dreschner <d4d4online@…>

Attachment: mythbackend.zip added

Mythbackend.log with verbose-option "all,nodatabase" and failed satellite-switching with DiseqC

comment:4 Changed 10 years ago by robertm

Status: infoneeded_newnew

comment:5 Changed 9 years ago by robertm

Owner: changed from Janne Grunau to Stuart Auchterlonie
Status: newassigned

comment:6 Changed 8 years ago by stuartm

Owner: changed from Stuart Auchterlonie to danielk
Type: defectBug Report - General
Version: headMaster Head

comment:7 Changed 4 years ago by Stuart Auchterlonie

Owner: danielk deleted
Status: assignednew

comment:8 Changed 4 years ago by Karl Egly

Status: newinfoneeded_new

Hi David, sorry for taking so long to get back to this ticket.

We've added support for repeating and resending DiSEqC commands in the upcoming 0.28 release, see #9726. Does repeating (support is present for some time now) or resending (that's new in the upcoming release) the command improve reliability?

Note: See TracTickets for help on using tickets.