Opened 9 years ago

Closed 9 years ago

#8292 closed defect (fixed)

Myth Backend Crashing under 10.6.3

Reported by: zachary.scholz@… Owned by: Nigel
Priority: minor Milestone: unknown
Component: Ports - OSX Version: 0.23rc1
Severity: high Keywords:
Cc: Ticket locked: no

Description

I built the newest myth release (r23912 (release-0-23-fixes)) and after a successful build, I attempt to start mythbackend and I get the error:

Application Specific Information: BUG IN CLIENT OF LIBDISPATCH: Do not close random Unix descriptors

I know that this problem was reported in ticket number 7582 and supposedly fixed in builds after 23099, but I'm still experiencing this problem.

At this point, mythbackend won't work at all on my mac(s).

Attachments (1)

Error_Report_Mythbackend.rtf (27.3 KB) - added by zachary.scholz@… 9 years ago.
Error Report

Download all attachments as: .zip

Change History (7)

Changed 9 years ago by zachary.scholz@…

Error Report

comment:1 Changed 9 years ago by Nigel

Hmmm. Tried with a few versions, cannot reproduce. e.g.:

% system_profiler SPSoftwareDataType | grep System
    System Software Overview:
      System Version: Mac OS X 10.6.3 (10D573)
% ./mythbackend --version
Please include all output in bug reports.
MythTV Version   : 23912
MythTV Branch    : branches/release-0-23-fixes
Network Protocol : 56
Library API      : 0.23.20100314-1
QT Version       : 4.6.0
Options compiled in:
 release darwin_da using_corevideo using_backend using_darwin using_disable_mmx_for_debugging using_frontend using_hdhomerun using_iptv using_lirc using_mheg using_opengl_video using_qtdbus using_qtwebkit using_appleremote using_bindings_perl using_bindings_python using_darwin_da using_opengl using_ffmpeg_threads using_live using_mheg
% ./mythbackend
2010-04-06 11:49:43.398 mythbackend version: branches/release-0-23-fixes [23912] www.mythtv.org
2010-04-06 11:49:43.400 Using runtime prefix = /Volumes/Backups/MythTV/.osx-packager/src/myth-svn/mythtv/programs/mythbackend
2010-04-06 11:49:43.400 Using configuration directory = /Users/nigel/.mythtv
2010-04-06 11:49:43.400 Using localhost value of MacBook.local
2010-04-06 11:49:43.402 New DB connection, total: 1
2010-04-06 11:49:43.404 Connected to database 'mythconverg' at host: 127.0.0.1
2010-04-06 11:49:43.404 Closing DB connection named 'DBManager0'
2010-04-06 11:49:43.405 Connected to database 'mythconverg' at host: 127.0.0.1
2010-04-06 11:49:43.410 Current MythTV Schema Version (DBSchemaVer): 1254
2010-04-06 11:49:43.413 MythBackend: Starting up as the master server.
2010-04-06 11:49:43.480 New DB connection, total: 2
2010-04-06 11:49:43.489 Connected to database 'mythconverg' at host: 127.0.0.1
2010-04-06 11:49:44.306 HDHRSH(192.168.0.13-0) Error: Unable to connect to device
2010-04-06 11:49:44.314 New DB connection, total: 3
2010-04-06 11:49:44.328 Connected to database 'mythconverg' at host: 127.0.0.1
2010-04-06 11:49:44.808 HDHRSH(192.168.0.13-0) Error: Get request failed
			eno: Resource temporarily unavailable (35)
2010-04-06 11:49:45.213 HDHRSH(192.168.0.13-0) Error: Set request failed
			eno: Resource temporarily unavailable (35)
2010-04-06 11:49:45.618 HDHRSH(192.168.0.13-0) Error: Get request failed
			eno: Resource temporarily unavailable (35)
2010-04-06 11:49:46.022 HDHRSH(192.168.0.13-0) Error: Set request failed
			eno: Resource temporarily unavailable (35)
2010-04-06 11:49:46.429 HDHRSH(192.168.0.13-0) Error: Get request failed
			eno: Resource temporarily unavailable (35)
2010-04-06 11:49:46.834 HDHRSH(192.168.0.13-0) Error: Set request failed
			eno: Resource temporarily unavailable (35)
2010-04-06 11:49:46.855 New DB scheduler connection
2010-04-06 11:49:46.856 Connected to database 'mythconverg' at host: 127.0.0.1
2010-04-06 11:49:46.941 MediaServer:: Loopback address specified - 127.0.0.1. Disabling UPnP
2010-04-06 11:49:46.941 Main::Registering HttpStatus Extension
2010-04-06 11:49:46.941 Enabled verbose msgs:  important general
2010-04-06 11:49:46.950 AutoExpire: CalcParams(): Max required Free Space: 1.0 GB w/freq: 15 min
2010-04-06 11:49:49.862 Reschedule requested for id -1.
2010-04-06 11:49:49.971 Scheduled 0 items in 0.1 = 0.06 match + 0.05 place
2010-04-06 11:49:49.976 Seem to be woken up by USER


Please double-check your source tree, and the binary you are running?

comment:2 Changed 9 years ago by Nigel

Resolution: worksforme
Status: newclosed

comment:3 in reply to:  2 Changed 9 years ago by Ojas Parekh <mythtv@…>

Resolution: worksforme
Status: closednew

Replying to nigel:

I can confirm that this bug has been an issue for me as well since release-0.22-fixes about 2 months ago. I built a fresh binary from release-0.23-fixes r24030 tonight and the issue hasn't been resolved for me. For what it's worth: Mac Mini 3,1 running 10.6.3 (as mentioned I also observed the issue on 10.6.2) with very little extra software installed. My assumption was that handle 4 was also being used by OS X in some undocumented way, which ended up yielding a fix for me:

Index: programs/mythbackend/main.cpp
===================================================================
--- programs/mythbackend/main.cpp	(revision 24030)
+++ programs/mythbackend/main.cpp	(working copy)
@@ -67,7 +67,7 @@
 
 #ifdef Q_OS_MACX
     // 10.6 uses handle 3 for its new Grand Central Dispatch thingy
-    #define UNUSED_FILENO 4 
+    #define UNUSED_FILENO 5 
 #else
     #define UNUSED_FILENO 3
 #endif

comment:4 Changed 9 years ago by Nigel

(In [24033]) Allow another file handle to be unmolested on OS X. Refs #8292. No idea why it doesn't crash on 10.6.3 for me. Thanks to Ojas for the fix!

comment:5 Changed 9 years ago by Nigel

(In [24034]) Backport [24033] from trunk. Allow another file handle to be unmolested on OS X. Refs #8292. No idea why it didn't crash on 10.6.3 for me. Thanks to Ojas for the fix!

comment:6 Changed 9 years ago by Nigel

Resolution: fixed
Status: newclosed

(In [24035]) Backport [24033] from trunk. Allow another file handle to be unmolested on OS X. Closes #8292. No idea why it didn't crash on 10.6.3 for me. Thanks to Ojas for the fix!

Note: See TracTickets for help on using tickets.