Opened 8 years ago

Closed 8 years ago

#8293 closed defect (Fixed)

Attempting to play a specific DVD fails drops back to mythfrontend DVD menu.

Reported by: Greg G. <spikeygg@…> Owned by: skamithi
Priority: minor Milestone: 0.24
Component: MythTV - DVD Playback Version: Master Head
Severity: low Keywords:
Cc: Ticket locked: no

Description

When I try to play "Army of Darkness", the FBI WARNING screen pops up for a split second then the internal player quits and dumps me back to the mythfrontend DVD menu. This happens on both my main myth machine and two remote frontend machines using VDPAU and ffmpeg. The ISO rip file works in windows media player. I will attach a log file of "mythfrontend -v playback" attempting to play the file. Please let me know if you need anything else.

Attachments (4)

army_of_darkness.log (39.2 KB) - added by Greg G. <spikeygg@…> 8 years ago.
Playback file of "Army of Darkness"
sabrina.log (13.4 KB) - added by Greg G. <spikeygg@…> 8 years ago.
Playback file of "Sabina"
heist.log (83.0 KB) - added by Greg G. <spikeygg@…> 8 years ago.
Playback file of "Heist"
gdb.txt (34.0 KB) - added by Greg G. <spikeygg@…> 8 years ago.
gdb debug results from attempting to play "An Affair to Remember"

Download all attachments as: .zip

Change History (16)

Changed 8 years ago by Greg G. <spikeygg@…>

Attachment: army_of_darkness.log added

Playback file of "Army of Darkness"

comment:1 Changed 8 years ago by Greg G. <spikeygg@…>

This DVD appears to work now that I have updated to SVN 25100. I am now, however, getting a segfault (kills mythfrontend) when I try to play "Sabrina". Also, "Heist" and "Dreams" both crash back to the DVD menu. I'll attach sabrina.log and heist.log.

Changed 8 years ago by Greg G. <spikeygg@…>

Attachment: sabrina.log added

Playback file of "Sabina"

Changed 8 years ago by Greg G. <spikeygg@…>

Attachment: heist.log added

Playback file of "Heist"

comment:2 Changed 8 years ago by Greg G. <spikeygg@…>

I just updated to svn trunk rev 25368, I then went through the first 130 movies in my collection (all hard drive ISO files). I wonder if I should open a couple more tickets because there appears to be three types of issues here. I separated them out below. Over 20% of the movies caused crashes to myth or the desktop (segfault).

I have three frontends (all SVN 25368). Two of them use VDPAU and one uses the CPU to crunch the video, all three have repeatable and consistent results. I didn't used to have this problem with playback of DVDs, I noticed the problem after updating to 25100 from 24785. I looked through the commits and 24972 sounds like it could be the culprit just based on the commit comments.

The following 17 movies crash back to the frontend menu when selecting the movie from mythdvd, or attempting to display the root menu of the dvd, or attempting to play the movie after selecting "play movie" from dvd's root menu:

Akira Kurosawa's Dream Army of Darkness Bandits My Sister's Keeper The Contract Everything Is Illuminated Heist The Great Gatsby Rumor Has It Captain Ron Criminal Defending Your Life The Departed The Emperor's New Groove Father of the Bride (1950) BUtterfield 8 European Vacation

The following 11 crash to the desktop with segfault: An Affair to Remember All About Eve Beverly Hillbillies Big Dead Again Sabrina Brewster's Millions Broadcast News Chronicles of Riddick Pitch Black Clue

The following 11 do not display the cursor when arriving at the DVD root menu: Adaptation. As Good As It Gets Awakenings Bad Boys Big Lebowski The Birdcage Black Hawk Down The Dark Crystal Death Becomes Her Devine Secrets of the Ya-ya Sisterhood Evolution

These two have broken menus: America's Sweethearts - DVD root-menu causes very fast music and does not update the video. Clockwork Orange - Cannot get to root-menu, automatically presses "play movie" and starts playback.

comment:3 Changed 8 years ago by robertm

Status: newinfoneeded_new

For any of these samples which cause a segfault, we need a backtrace per the manual, please. It would help to determine if upstream lib changes will fix them, or whether the problem is local to myth.

http://www.mythtv.org/wiki/Debugging

Changed 8 years ago by Greg G. <spikeygg@…>

Attachment: gdb.txt added

gdb debug results from attempting to play "An Affair to Remember"

comment:4 Changed 8 years ago by Greg G. <spikeygg@…>

Okay, I used a --compile-type=profile build to generate this from your debugging link, and I used the instructions found here to generate the gdb.txt file: http://www.mythtv.org/docs/mythtv-HOWTO-22.html#ss22.2

I haven't done a backtrace before... hopefully it's useful. Let me know if you need a --compile-type=debug result or anything else.

comment:5 Changed 8 years ago by robertm

Greg, just to confirm, this disc plays properly in VLC?

comment:6 Changed 8 years ago by Greg G. <spikeygg@…>

Yes they work with VLC, I just tried a random sample of the segfaulting DVDs including the one I generated the debug results for.

comment:7 Changed 8 years ago by robertm

Please test against trunk r25514 or later, now includes up to date libdvdnav/read. Please feel free to report results of all classes of failures, but particularly the segfaults.

comment:8 Changed 8 years ago by Greg G. <spikeygg@…>

I just updated to SVN revision 25524. I have tested about twenty of the movies, a set from each group (segfaults, crash back to myth, and no DVD menu cursors) and they all have the same problems that they did on SVN 25368. If you would like me to recapture a segfault (or anything else) just let me know.

comment:9 Changed 8 years ago by robertm

Status: infoneeded_newnew

comment:10 Changed 8 years ago by robertm

Status: newassigned

comment:11 Changed 8 years ago by Greg G. <spikeygg@…>

I have tried several "problem" DVDs on r26972 this morning after reading all about markk's updates to the DVD playback module. Many movies from each category appear to work much better now, no segfaults and no dropping back to myth. This ticket can be closed out.

comment:12 Changed 8 years ago by paulh

Milestone: unknown0.24
Resolution: Fixed
Status: assignedclosed
Version: unknownTrunk Head
Note: See TracTickets for help on using tickets.