Opened 10 years ago

Closed 9 years ago

#8330 closed defect (Fixed)

Editing recording in progress auto adds 'in' cutpoint after 'out' is set

Reported by: highzeth Owned by: Janne Grunau
Priority: minor Milestone: 0.24
Component: MythTV - General Version: 0.22-fixes
Severity: low Keywords: edit running recording cutpoints
Cc: Ticket locked: no

Description

I dont happen to watch much "livetv", but today Ive caught up with several recordings while they happen. And while doing so Ive edited out any unwanted content. Since many channels dont seem to uphold any relations to the concept of keeping time, I have 10min+ post time padding on them. Commflag is disabled system & channel wide.

Im a tad unsure if its a design choice/fail safe or a bug, so let me bullet-point the scenario;

- Start to watch & edit a recording thats in progress
- You catch up to the end of the broadcast and add your last cutpoint(out)
- You exit edit submenu & in turn end up back in the rec menu

(all is well so far)

- After a little while re-entering the edit submenu shows that the 
BE has set a 'in' cutpoint on the remains of the recording(past 
'out' cutpoint). The 'out'/unmarked segment you end up with before 
the 'BE-set' 'in' seem to correspond with the time spent in 'edit' 
menu after 'out' cutpoint is set.

(other cutpoints are a-ok)

(rant)

This has happened a few times in the past, seeing the extra content at the end of those recordings(while viewing at a much later time). Since I watch "livetv" so rarely I filed it under PEBKAC, but today has shown its indeed reproductible.

If this is a design choice/fail-safe, why would it be considered less important to uphold user cutpoints vs commflag? Specifically in a 'auto transcode to several formats after rec is done' scenario this adds a bit of grumble. Im not asking for a in-progress recording to stop at the 'out' cutpoint, let it end at its intended time, but leave the remaining content as 'out'/unmarked as per the edit.

Filed under general, as Im not quite sure where it should otherwise be, commflag? transcode? recording?

(/rant)

Minor annoyance in a otherwise long & bug free myth relationship.

0-22-fixes - 23953

Feel free to ping me in the channel if more info is needed or if you need to beat some sense into me.

Change History (3)

comment:1 Changed 10 years ago by Janne Grunau

Owner: changed from Isaac Richards to Janne Grunau
Status: newassigned

comment:2 Changed 9 years ago by highzeth

This is fixed in 0.24, cheers! =)

comment:3 Changed 9 years ago by robertm

Milestone: unknown0.24
Resolution: Fixed
Status: assignedclosed
Note: See TracTickets for help on using tickets.