Opened 10 years ago

Closed 9 years ago

#8361 closed defect (fixed)

ALSA audio capture doesn't work with snd-bt87x driver [PATCH INCLUDED]

Reported by: Carlos Azevedo <geral@…> Owned by: JYA
Priority: minor Milestone: unknown
Component: MythTV - Recording Version: 0.23rc2
Severity: low Keywords:
Cc: Ticket locked: no

Description

I sent this patch to the dev mailing list in Dec/09 and it probably still waits for moderation. So would please someone review and apply this thing once and for all ?

The ALSA initialization code is convoluted and does not work with snd-bt87x; LiveTV starts with audio but as soon as I try to change channel it stalls, goes black and then shows Irrecoverable recorder error. At the time I did the analysis and was included in the email to the dev-list. Since this still happens with 0.23-fixes[24158] I'm now posting the patch here. It was based on the initialization code of arecord (the recording utility that comes with ALSA).

Attachments (1)

audioinputalsa.patch (3.9 KB) - added by Carlos Azevedo <geral@…> 10 years ago.
Patch for ALSA snd-bt87x support

Download all attachments as: .zip

Change History (7)

Changed 10 years ago by Carlos Azevedo <geral@…>

Attachment: audioinputalsa.patch added

Patch for ALSA snd-bt87x support

comment:1 Changed 10 years ago by robertm

Milestone: 0.23unknown
Priority: majorminor
Severity: highlow

Please see the ticket howto, milestones are for developer use.

comment:2 Changed 10 years ago by Carlos Azevedo <geral@…>

As requested via IRC, I'm adding a quote from http://www.mythtv.org/wiki/ALSA,_BTTV_and_MythTV_0.22, which a wrote at the time:

"Everytime I tried to use the board for capture MythTV would error out about not being able to set the sample rate (wanted 48000, the driver reported 119466 sp/s), not being able to set the number of channels (wanted two, the driver only reported one) and some other errors"

I never got around to debugging the interaction of the MythTv?'s initialization code with ALSA, I simply looked at the code for arecord that does the same initialization in a much simplified mannor, plugged it in and it worked. I don't understand why the current code does it in such a roundabout way, but my way does work, and should work with all BTTV-based setups. Setups with others kinds of capture cards may require that kind of initialization but I doubt it.

P.S. This patch has to be applied inside libs/libmythtv

comment:3 Changed 10 years ago by robertm

Status: newassigned

comment:4 Changed 10 years ago by danielk

Owner: changed from danielk to JYA

comment:5 Changed 10 years ago by JYA

Status: assignedinfoneeded

This part of the code was rewritten in trunk... Please check that the issue is still occurring with trunk and report back or close the ticket

comment:6 Changed 9 years ago by JYA

Resolution: fixed
Status: infoneededclosed

(In [26261]) Fixes #8361. Patch by Carlos Azevedo. Untested, but as I'm guessing very few people actually use this feature

Note: See TracTickets for help on using tickets.