Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#8362 closed patch (duplicate)

WriteAudio: buffer underrun during playback of CD audio

Reported by: dev@… Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: Plugin - MythMusic Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

This patch is related to the ticket 7784.

The correction is working well for me for most of CDs. The main correction is to change the paranoia buffer. A samller buffer result in smaller latencies and the ouput buffer will no underrun.

Attachments (2)

cddecoder.cpp.patch (5.2 KB) - added by dev@… 10 years ago.
Patch for cddecoder.cpp file
cddecoder.h.patch (391 bytes) - added by dev@… 10 years ago.
Patch for cddecoder.h file

Download all attachments as: .zip

Change History (7)

Changed 10 years ago by dev@…

Attachment: cddecoder.cpp.patch added

Patch for cddecoder.cpp file

Changed 10 years ago by dev@…

Attachment: cddecoder.h.patch added

Patch for cddecoder.h file

comment:1 Changed 10 years ago by Paul <paul@…>

thanks, but do I read this as a partial fix, ie working for "most CDs" ?

comment:2 Changed 10 years ago by robertm

Resolution: duplicate
Status: newclosed

Dupe of #7784.

comment:3 Changed 10 years ago by Paul <paul@…>

note 7784 has no solution yet.. and 7784 refers to this one.. so I'm confused where to look.. and I can't update the other ticket so I assume we have to wait for the next release to test.

comment:4 in reply to:  1 Changed 10 years ago by dev@…

Replying to Paul <paul@…>:

thanks, but do I read this as a partial fix, ie working for "most CDs" ?

When the CD is hard to read with some scratch, there is no sound at all. The cdda_paranoia library try to recover the errors and is skipping data, and I think never returns.

comment:5 Changed 10 years ago by robertm

Discussion on the development list, please.

Note: See TracTickets for help on using tickets.