Opened 9 years ago

Closed 9 years ago

Last modified 8 years ago

#8376 closed patch (fixed)

Patch for mythburn.py

Reported by: J.Pilk@… Owned by: paulh
Priority: minor Milestone: 0.23
Component: Plugin - MythArchive Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

I've been using modified versions of mythburn.py for many months to work around problems that I had with the standard mytharchive DVD-creation process. I now use the script at ticket 8347 and the attached diff to process recordings from dvb-t in the UK. I don't claim that it will work with all the options offered by mytharchive but it does work for me. I don't save subtitles or the secondary audio stream - in part because mythtranscode never did. I select the required streams and apply the cutlist before entering mytharchive so that the file sizes are known when I decide the table of contents. I don't transcode within mytharchive. Issues addressed are:

It can use M2VRequantiser instead of tcrequant. Both programs are based on code from the same company but tcrequant did have problems and has been deprecated. M2VRequantiser needs to know input file size, so it cannot pipe the demux products for remuxing. remux errors that were declared fatal outside the pipe are now ignored, just as they always have been within the pipe.

If requantisation is needed, because the files selected are too big for the DVD, it is used to apply a common mean-video-bitrate limit to all the files on the disk. This means that programmes transmitted at low bitrates can be saved without further degradation.

Other changes are to make the log files more useful and to suppress complaints about "odd y-coordinates"

The file was created with

diff mythburn_distrib.py mythburn.py > mythburn20100420.diff

Attachments (2)

mythburn20100420.diff (19.3 KB) - added by anonymous 9 years ago.
mythburn20100423.patch (29.1 KB) - added by J.Pilk@… 9 years ago.

Download all attachments as: .zip

Change History (14)

Changed 9 years ago by anonymous

Attachment: mythburn20100420.diff added

comment:1 Changed 9 years ago by J.Pilk@…

I forgot to say that the patch will look for 'intro' and 'menumusic' files with mp2 sound format.

This only applies to the last few lines of the patch, which can be omitted. I wanted to create DVDs with all-mp2 sound because the internal player seemed to have trouble switching formats. AFAIK it still has mp2-related problems.

comment:2 Changed 9 years ago by robertm

Component: MythTV - GeneralPlugin - MythArchive
Owner: changed from Isaac Richards to paulh
Version: UnspecifiedTrunk Head

Changed 9 years ago by J.Pilk@…

Attachment: mythburn20100423.patch added

comment:3 Changed 9 years ago by anonymous

Attaching unified patch as requested - diff -Nau mythburn_dist.py mythburn.py > mythburn20100423.patch

comment:4 Changed 9 years ago by gigem

(In [24416]) Changed MythArchive? to use M2VRequantiser when the MPEG2 video needs to be shrunk to fit onto the specified media. This replaces the use of tcrequant which is considered broken by its author. Thanks to John Pilkington for the original patch on which this is based. Refs #8376.

comment:5 Changed 9 years ago by J.Pilk@…

It looks as if this would be useful too: relates to sutitles and language selection. http://www.gossamer-threads.com/lists/mythtv/users/436878#436878

comment:6 Changed 9 years ago by J.Pilk@…

I just had a failure in DVD creation using this patched version of mythburn.py (#8376). It followed experiments using the Project-X GUI which left a modified version of ~/X.ini. $RECDIR/X.ini was not changed. If it existed it would be used by mythcutprojectx (#8347) Everything seems to work as intended with the configuration which is used if no X.ini is found in the expected location.

comment:7 Changed 9 years ago by robertm

Resolution: fixed
Status: newclosed

comment:8 Changed 9 years ago by stuartm

Milestone: unknown0.23

comment:9 Changed 9 years ago by J.Pilk@…

Part of my original patch was committed to trunk but other sections remain in limbo. Probably the most significant remaining changes were those made to stop remux 'failures' terminating the entire job. I still see such failures occasionally, almost always like this:

INFO: [mplex] Run-in delay = 7200 Video delay = 7200 Audio delay = 10800 INFO: [mplex] New sequence commences... INFO: [mplex] Video e0: buf= 0 frame=000000 sector=00000000 INFO: [mplex] Audio c0: buf= 0 frame=000000 sector=00000000

++ WARN: [mplex] Stream e0: data will arrive too late sent(SCR)=7314 required(DTS)=7200 ++ WARN: [mplex] Video e0: buf= 101237 frame=000000 sector=00000050 ++ WARN: [mplex] Audio c0: buf= 0 frame=000000 sector=00000000

INFO: [mplex] Scanned to end AU 42153 INFO: [mplex] STREAM e0 completed INFO: [mplex] STREAM c0 completed INFO: [mplex] Multiplex completion at SCR=151755337.

followed by

ERROR: [mplex] MUX STATUS: Frame data under-runs detected!

which would trigger process failure.

The values in the line

++ WARN: [mplex] Stream e0: data will arrive too late sent(SCR)=7314 required(DTS)=7200

are nearly always the same and I wonder if this might be a problem within mplex. I have never noticed any adverse effects when a DVD is created after a report like this.

I still run the fixes branch with a slightly modified and updated version of my original patch. I haven't seen the current trunk version in operation.

comment:10 Changed 9 years ago by J.Pilk@…

When I wrote Comment #9 above I was still using the 2006 'Release' version of Project-X. Since then I found the tarball for a more recent patched version, and I have been using that. In a few weeks of intensive use since then I don't recall seeing any reported 'Errors' of this kind. In the logs from mythcutprojectx (http://www.mythtv.org/wiki/Mythcutprojectx) it identifies itself as ProjectX 0.90.4.00.b32/30.12.2009 TEST PROJECT ONLY. It can be downloaded from the foot of this page: http://project-x.cvs.sourceforge.net/viewvc/project-x/Project-X/

comment:11 Changed 8 years ago by J.Pilk@…

Update to comments 9 and 10 above re occasional reported failures of mplex. I had thought that these might have been cured by using an updated version of Project-X, but in fact I still see them, infrequently, with most parameters identical to those quoted above. The most recent version of ProjectX 0.91.0.02/13.08.2011 TEST PROJECT ONLY, can now be downloaded as a tarball from the foot of http://project-x.cvs.sourceforge.net/project-x/Project-X/

As stated before, I have seen/heard no bad effects of this 'Error' provided that mythburn.py is patched to continue when it is reported.

comment:12 Changed 8 years ago by J.Pilk@…

An updated version of the uncommitted parts of this patch and the one from #9389 is combined with other changes at ticket #10071.

Note: See TracTickets for help on using tickets.