Opened 10 years ago

Closed 10 years ago

#8382 closed defect (invalid)

FAAD change sound configuration!

Reported by: psgman24@… Owned by: Isaac Richards
Priority: trivial Milestone: unknown
Component: MythTV - Audio Output Version: 0.23rc2
Severity: low Keywords: faad
Cc: Ticket locked: no

Description

Hello! I'm using mythtv in Japan, here the channel use FAAD but it's change very often (when CM come,...) of sound configuration! Like the movie is in Stereo but the CM in Mono,... And when the sound change all bug! Few patch already exist for mplayer or gstreamer and it's working well in these software! is it possible to make a patch in mythtv like in these software?

Thank you very much!

Attachments (5)

Faad2.Patch (8.1 KB) - added by psgman24@… 10 years ago.
First patch for mplayer (libfaad)
Faad2-1.Patch (8.2 KB) - added by psgman24@… 10 years ago.
Second patch for mplayer (libfaad)
Faad.Patch (3.9 KB) - added by psgman24@… 10 years ago.
Gstreamer patch 1
Faad-1.Patch (721 bytes) - added by psgman24@… 10 years ago.
Gstreamer patch 2
Libgstfaad.So (96.3 KB) - added by psgman24@… 10 years ago.
Gstreamer patch 3

Download all attachments as: .zip

Change History (9)

comment:1 Changed 10 years ago by robertm

Component: MythTV - GeneralMythTV - Audio Output
Milestone: 0.23unknown
Priority: majortrivial
Severity: highlow
Status: newinfoneeded_new

Psgman,

you are going to need to be a lot clearer about what exactly the problem is. Please attach logs of the problem when running the frontend as "mythfrontend -v playback".

Also, please read the ticket howto, do not set milestones or severity on tickets.

comment:2 in reply to:  description Changed 10 years ago by anonymous

Replying to psgman24@…:

Hello! I'm using mythtv in Japan, here the channel use FAAD but it's change very often (when CM come,...) of sound configuration! Like the movie is in Stereo but the CM in Mono,... And when the sound change all bug! Few patch already exist for mplayer or gstreamer and it's working well in these software! is it possible to make a patch in mythtv like in these software?

Thank you very much!

I'm sorry if I didn't explain correctly, When we use faad, and when during playing the sound configuration change (from setero to mono, from 5.1 to stereo,...), all cut! I have to start again TV. I join you the link of the patch was make by the japanese community for fix it in mplayer en Gstreamer, http://2sen.dip.jp/cgi-bin/dtvup/source/up0319.zip

This problem is not only for mythtv, ALL the video software using libfaad have it! Only the mplayer's and Gstreamer's patch are working! Is it possible to make a patch like this for mythtv?

comment:3 Changed 10 years ago by robertm

psgman,

We still need the logs I asked for. Also, the "patch" you linked is a zip of DVB-apps, which has nothing at all to do with libfaad, gstreamer, or video playback. Wrong link?

comment:4 Changed 10 years ago by robertm

Resolution: invalid
Status: infoneeded_newclosed

Ref:

http://trac.videolan.org/vlc/ticket/3238 http://trac.videolan.org/vlc/attachment/ticket/3238/Mplayer%20faad2.patch

Above ticket was posted by the same poster as this ticket, most of the patch is in libfaad, and appears to be a largely a libfaad bug. In fact, every reference I can find to this issue is by the above poster. There may be Myth code that needs changing, but the problem probably needs to get fixed in libfaad for us to do anything about it.

Changed 10 years ago by psgman24@…

Attachment: Faad2.Patch added

First patch for mplayer (libfaad)

Changed 10 years ago by psgman24@…

Attachment: Faad2-1.Patch added

Second patch for mplayer (libfaad)

Changed 10 years ago by psgman24@…

Attachment: Faad.Patch added

Gstreamer patch 1

Changed 10 years ago by psgman24@…

Attachment: Faad-1.Patch added

Gstreamer patch 2

Changed 10 years ago by psgman24@…

Attachment: Libgstfaad.So added

Gstreamer patch 3

Note: See TracTickets for help on using tickets.