Opened 9 years ago

Closed 7 years ago

#8394 closed defect (Invalid)

When watching a recording, up and down arrows will activate jump forward and jump back even though all key bindings are removed

Reported by: Peter Semple <petersemple@…> Owned by: Janne Grunau
Priority: minor Milestone: unknown
Component: MythTV - Video Playback Version: 0.22
Severity: medium Keywords: overload, keybindings
Cc: Ticket locked: no

Description

When watching a recording, the up and down arrow keys will activate the jump forward and jump back functions. This will lead to the recording jumping by the defined number of minutes. This happens even after all keybindings are removed from the jump forward and jump back functions in Edit Keys. It can be a particular pain with a keyboard or remote that generates these signals due to interference.

Change History (9)

comment:1 Changed 9 years ago by robertm

Status: newinfoneeded_new

Is this report actually against .21?

comment:2 Changed 9 years ago by sphery

Please attach the output of: mythbackend --version

comment:3 in reply to:  1 Changed 9 years ago by Peter Semple <petersemple@…>

Replying to robertm:

Is this report actually against .21?

Oops, sorry, it is against 0.22. It is from a clean install of mythbuntu 9.10. I was sure this had 0.21, but have just double checked and it seems to be based on 0.22. My bad.

comment:4 Changed 9 years ago by sphery

Status: infoneeded_newnew

This ticket is actually the opposite of #2275 .

comment:5 Changed 9 years ago by sphery

Keywords: overload keybindings added
Resolution: invalid
Status: newclosed
Version: 0.210.22

I'm closing this ticket as invalid, but I'm acknowledging the problem described by the ticket /is/ valid and is being addressed. The behavior the reporter is seeing is expected (even if not always desirable) behavior caused by the changes in #2275--where the reporter in #2275 wanted the exact opposite behavior Peter wants.

As discussed in http://www.gossamer-threads.com/lists/mythtv/dev/434203#434203 , the behavior is the unwanted side effect of overloading of keybindings--where #2275 added such an overload. A planned refactoring of keybindings in MythTV will allow the behavior the reporter wants, but a lot of changes need to be completed to make this possible. I have a plan for fixing the underlying issue and allowing complete control over configuration, but it will take time to implement the plan. In the mean time, this ticket is pretty much a feature request without a patch. Note that closing the ticket does not change the priority of the changes I have planned.

(Sorry for the double post. My MS mouse's sending random mouse wheel events led to my submitting an incomplete comment when trying to select the resolution.)

comment:6 in reply to:  5 Changed 9 years ago by Peter Semple <petersemple@…>

Thanks.

I checked out the thread at Gossamer threads and that exactly describes the issue, so it sounds like it is in hand. In the meantime, I have solved my specific frustration by buying a new keyboard that doesn't have the same problem with spurious keypresses, so it doesn't affect my watching of recordings now.

Thanks for all your hard work

comment:7 Changed 7 years ago by max78@…

It looks like this problem is still not fixed. I was looking to swap the up/down keys to be consistent with human logic (and XBMC) but it appears that that this is still hardcoded. Is there any other solution for users rather then starting to mess around in the code?

comment:8 Changed 7 years ago by max78@…

Resolution: invalid
Status: closednew

comment:9 Changed 7 years ago by sphery

Resolution: Invalid
Status: newclosed

See comment:5

Note: See TracTickets for help on using tickets.