Opened 9 years ago

Closed 9 years ago

#8409 closed defect (fixed)

1088 height rounding causes VDPAU playback problems on a VC1 video

Reported by: anonymous Owned by: markk
Priority: minor Milestone: 0.24
Component: MythTV - Video Playback Version: 0.23rc2
Severity: medium Keywords:
Cc: Ticket locked: no

Description

I noticed some 100% reproducible artifacting near the bottom of the picture playing back a 1920x1080 VC1 video. mplayer didn't produce this artifacting. I turned on VDPAU tracing and noticed that mplayer always passed 1080 as a height where mythtv would sometimes pass 1088. I changed this and the artifacting vanished. A patch is attached.

Attachments (1)

mythtv_vdpau.patch (519 bytes) - added by anonymous 9 years ago.

Download all attachments as: .zip

Change History (5)

Changed 9 years ago by anonymous

Attachment: mythtv_vdpau.patch added

comment:1 Changed 9 years ago by markk

Owner: changed from Janne Grunau to markk
Status: newaccepted

comment:5 Changed 9 years ago by markk

Milestone: unknown0.24

This should be a relatively straightforward fix but I really need a VC1 clip with 1088 height to test properly and ensure there are no regressions. If you can upload a short (30s) clip, that would be much appreciated.

comment:6 Changed 9 years ago by robertm

Status: acceptedinfoneeded

Going to need this sample if you want anything done with this (not holding out a lot of hope since this ticket is anonymous)

comment:4 Changed 9 years ago by markk

Resolution: fixed
Status: infoneededclosed

(In [26072]) Always use the actual video dimensions for VDPAU hardware buffers and decoders.

I can't see any regressions here but it certainly fixes the infamous corrupted bottom line on the HDPVR clips I have.

Closes #8409 - or at least it should.

Note: See TracTickets for help on using tickets.