Opened 10 years ago

Closed 9 years ago

#8421 closed defect (invalid)

mythbackend from trunk rev 24416 crashes while scanning video directory in libQtCore.so.4

Reported by: dj_maarten@… Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: MythTV - General Version: Master Head
Severity: high Keywords: mythbackend crash libqtcore.so.4
Cc: Ticket locked: no

Description

Recently updated my mythtv version from trunk. When I startup mythbackend it crashes after 5 seconds. The last line in mythbackend log file shows UPnpMedia: BuildMediaMap? VIDEO scan starting in :/home/mythtv/video

When I use gdb (debugger) this is the output from startup. It seems to crash in libqtcore.so.4

# gdb mythbackend GNU gdb (GDB) 7.1-ubuntu Copyright (C) 2010 Free Software Foundation, Inc. License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html> This is free software: you are free to change and redistribute it. There is NO WARRANTY, to the extent permitted by law. Type "show copying" and "show warranty" for details. This GDB was configured as "x86_64-linux-gnu". For bug reporting instructions, please see: <http://www.gnu.org/software/gdb/bugs/>... Reading symbols from /usr/local/bin/mythbackend...(no debugging symbols found)...done. (gdb) run Starting program: /usr/local/bin/mythbackend [Thread debugging using libthread_db enabled] 2010-05-05 16:09:49.040 mythbackend version: trunk [24416] www.mythtv.org 2010-05-05 16:09:49.041 Using runtime prefix = /usr/local 2010-05-05 16:09:49.041 Using configuration directory = /home/woef/.mythtv 2010-05-05 16:09:49.042 Using localhost value of kubrick [New Thread 0x7fffe9b82710 (LWP 4069)] [Thread 0x7fffe9b82710 (LWP 4069) exited] 2010-05-05 16:09:49.100 New DB connection, total: 1 2010-05-05 16:09:49.107 Connected to database 'mythnew' at host: localhost 2010-05-05 16:09:49.107 Closing DB connection named 'DBManager0' 2010-05-05 16:09:49.108 Connected to database 'mythnew' at host: localhost 2010-05-05 16:09:49.111 Current MythTV Schema Version (DBSchemaVer): 1254 [New Thread 0x7fffe9b82710 (LWP 4070)] [New Thread 0x7fffe9174710 (LWP 4071)] 2010-05-05 16:09:49.127 Enabling Upnpmedia rebuild thread. [New Thread 0x7fffe8973710 (LWP 4072)] [New Thread 0x7fffe3fff710 (LWP 4073)] 2010-05-05 16:09:50.334 MythBackend?: Starting up as the master server. 2010-05-05 16:09:50.342 New DB connection, total: 2 2010-05-05 16:09:50.343 Connected to database 'mythnew' at host: localhost 2010-05-05 16:09:50.541 New DB connection, total: 3 2010-05-05 16:09:50.542 Connected to database 'mythnew' at host: localhost 2010-05-05 16:09:50.543 New DB connection, total: 4 2010-05-05 16:09:50.544 Connected to database 'mythnew' at host: localhost 2010-05-05 16:09:50.546 New DB connection, total: 5 2010-05-05 16:09:50.546 Connected to database 'mythnew' at host: localhost 2010-05-05 16:09:50.547 New DB connection, total: 6 2010-05-05 16:09:50.548 Connected to database 'mythnew' at host: localhost [New Thread 0x7fffe37fe710 (LWP 4076)] [New Thread 0x7fffe2ffd710 (LWP 4077)] 2010-05-05 16:09:52.384 DVBChan(24:/dev/dvb/adapter2/frontend0) Warning: Your frequency setting (12187000) is out of range. (min/max:950000/2150000) [New Thread 0x7fffe27fc710 (LWP 4078)] [New Thread 0x7fffe1ffb710 (LWP 4080)] [New Thread 0x7fffe17fa710 (LWP 4081)] 2010-05-05 16:09:52.582 TVRec(26) Error: Problem finding starting channel, setting to default of '3'. 2010-05-05 16:09:52.583 ChannelBase?(26) Error: InitializeInputs?():

Could not get inputs for the capturecard. Perhaps you have forgotten to bind video sources to your card's inputs?

2010-05-05 16:09:52.586 TVRec(27) Error: Problem finding starting channel, setting to default of '3'. 2010-05-05 16:09:52.587 ChannelBase?(27) Error: InitializeInputs?():

Could not get inputs for the capturecard. Perhaps you have forgotten to bind video sources to your card's inputs?

2010-05-05 16:09:52.590 TVRec(28) Error: Problem finding starting channel, setting to default of '3'. 2010-05-05 16:09:52.591 ChannelBase?(28) Error: InitializeInputs?():

Could not get inputs for the capturecard. Perhaps you have forgotten to bind video sources to your card's inputs?

2010-05-05 16:09:52.593 New DB scheduler connection 2010-05-05 16:09:52.594 Connected to database 'mythnew' at host: localhost [New Thread 0x7fffe0ff9710 (LWP 4082)] [New Thread 0x7fffe07f8710 (LWP 4083)] [New Thread 0x7fffdfff7710 (LWP 4084)] [New Thread 0x7fffdf7f6710 (LWP 4085)] 2010-05-05 16:09:52.607 Main::Registering HttpStatus? Extension 2010-05-05 16:09:52.608 Enabled verbose msgs: important general 2010-05-05 16:09:52.608 AutoExpire?: ERROR: Filesystem Info cache is empty, unable to calculate necessary parameters. [New Thread 0x7fffdeff5710 (LWP 4086)] [New Thread 0x7fffde7f4710 (LWP 4087)] [New Thread 0x7fffddff3710 (LWP 4088)] [New Thread 0x7fffdd7f2710 (LWP 4089)] [New Thread 0x7fffdcff1710 (LWP 4090)] 2010-05-05 16:09:55.613 Reschedule requested for id -1. 2010-05-05 16:09:55.701 Scheduled 10 items in 0.1 = 0.01 match + 0.07 place 2010-05-05 16:09:55.704 Seem to be woken up by USER [New Thread 0x7fffdc7f0710 (LWP 4092)] 2010-05-05 16:09:56.872 MainServer::ANN Monitor 2010-05-05 16:09:56.873 adding: kubrick as a client (events: 0) 2010-05-05 16:09:56.874 MainServer::ANN Monitor 2010-05-05 16:09:56.874 adding: kubrick as a client (events: 1) 2010-05-05 16:09:59.511 UPnpMedia: BuildMediaMap? VIDEO scan starting in :/home/mythtv/video:

Program received signal SIGSEGV, Segmentation fault. [Switching to Thread 0x7fffe8973710 (LWP 4072)] 0x00007ffff1bf0a1f in QFSFileEngine::fileName(QAbstractFileEngine::FileName?) const () from /usr/lib/libQtCore.so.4 (gdb)

Change History (2)

comment:1 Changed 10 years ago by robertm

Status: newinfoneeded_new

Your whole system is badly misconfigured, and this backtrace is unusable (in fact, it's not even a backtrace)-- please provide a backtrace per the manual:

http://www.mythtv.org/docs/mythtv-HOWTO-22.html#ss22.2

Also, did you clear out your old libs before installing this version?

rm /usr/local/lib/libmyth*

comment:2 Changed 9 years ago by robertm

Resolution: invalid
Status: infoneeded_newclosed

No response, and almost undoubtedly a dirty build/install.

Note: See TracTickets for help on using tickets.