Opened 10 years ago

Closed 10 years ago

#8426 closed defect (fixed)

mythgallery does not follow xorg.conf aspect ratio for non-square pixels

Reported by: Woodhouse Owned by: Isaac Richards
Priority: trivial Milestone: unknown
Component: Plugin - MythGallery Version: 0.23rc3
Severity: low Keywords: aspect ratio no-square pixels gallery
Cc: Ticket locked: no

Description

I stretch a 720x576 resolution fullscreen onto a 16:9 monitor. This means non-square pixels. I have set DisplaySize? in xorg.conf (Monitor section) to the 16:9 size of my monitor. Xorg will calculate non square DPI values (something like 70 x100). The mythtv interface (fonts) adjusts well to this setting. All video is displayed correctly (4:3 broadcast with black bars l and R and 16:9 filling full screen). Mythgallery will however not follow the DPI/Displaysize setting. All images will be as if on 4:3 and then stretched to 16:9 resulting in very wide images with "fat" people.

This is regression as it worked properly on my previous mythbuntu 9.04 setup. (mythtv 0.22). Now on 10.04 using weekly builds we have a problem!

Change History (15)

comment:1 Changed 10 years ago by robertm

Milestone: 0.23unknown
Priority: majortrivial
Severity: highlow

Please read the tickethowto, as you were prompted to do when opening the ticket. Milestone, priority, and severity are to be left at defaults in the future, please.

comment:2 in reply to:  1 Changed 10 years ago by Woodhouse

Sorry about the Prio/sev/milestone mistake.

Please take into consideration that gallery is not usable in this way for anyone using non square pixels: those using myth on 16:9 wide screen SD television sets.

comment:3 Changed 10 years ago by stuartm

Status: newinfoneeded_new

We need more detail. Which images, the thumbnails or the fullscreen image? Which theme are you using?

comment:4 in reply to:  3 Changed 10 years ago by Woodhouse

Replying to stuartm:

We need more detail. Which images, the thumbnails or the fullscreen image? Which theme are you using?

-Happens equally with any theme installed, but I use mediacenter wide mostly -The thumbnails do not seem to have the problem and are of no concern anyway. -I am talking about the fullscreen image

comment:5 Changed 10 years ago by stuartm

Status: infoneeded_newnew

Thanks for the response. This isn't going to be a quick fix, there have been zero changes in mythgallery between 0.22 and 0.23. The fullscreen image code doesn't use the common ui libs so at this moment in time I can't come up an explanation, it appears to have broken for no reason at all.

comment:6 in reply to:  5 ; Changed 10 years ago by Jonatan <mythtv@…>

Replying to stuartm:

Thanks for the response. This isn't going to be a quick fix, there have been zero changes in mythgallery between 0.22 and 0.23. The fullscreen image code doesn't use the common ui libs so at this moment in time I can't come up an explanation, it appears to have broken for no reason at all.

I think there are two issues here. The first one is that MythGetPixelAspectRatio?() returns 1.0 since 0.22. The second is that QImage::ScaleFree? should have been replaced with Qt::IgnoreAspectRatio? instead of Qt::KeepAspectRatio? when porting to Qt4.

comment:7 in reply to:  6 Changed 10 years ago by anonymous

Replying to Jonatan <mythtv@…>:

Replying to stuartm:

Thanks for the response. This isn't going to be a quick fix, there have been zero changes in mythgallery between 0.22 and 0.23. The fullscreen image code doesn't use the common ui libs so at this moment in time I can't come up an explanation, it appears to have broken for no reason at all.

I think there are two issues here. The first one is that MythGetPixelAspectRatio?() returns 1.0 since 0.22. The second is that QImage::ScaleFree? should have been replaced with Qt::IgnoreAspectRatio? instead of Qt::KeepAspectRatio? when porting to Qt4.

Does this mean that you know where the problem lies and a fix me be quite straightforward?

comment:8 Changed 10 years ago by stuartm

(In [24436]) Use MythUIHelper::GetPixelAspectRatio?() instead of the defunct MythGetPixelAspectRatio?() in mythgallery. Also fix a QT4 porting error which changed the scaling logic. Potentially fixes image stretching on non-square pixel displays. Refs #8426

comment:9 Changed 10 years ago by stuartm

Status: newinfoneeded_new

Please let us know if [24436] fixes the issue. It addresses the problems noticed by Jonatan, but both were introduced prior to 0.22 and you stated that the problem was introduced with 0.23 so ...

Otherwise, please keep discussion and questions to the mailing list. Trac is not a forum.

comment:10 Changed 10 years ago by stuartm

(In [24602]) Backport [24436] to 0.23-fixes. Use MythUIHelper::GetPixelAspectRatio?() instead of the defunct MythGetPixelAspectRatio?() in mythgallery. Also fix a QT4 porting error which changed the scaling logic. Potentially fixes image stretching on non-square pixel displays. Refs #8426

comment:11 Changed 10 years ago by judithc@…

I've updated to current 0.23-fixes ( rev 24609 ) and mythgallery on 16:9 SD is now showing a section of the image as though it is scaled incorrectly it is like zoomed in. I can't tell whether the non-square problem still exists as it only shows about 50% of he image.

comment:12 Changed 10 years ago by robertm

What happens if you turn on "scale to fit?" (Believe it's "W" to cycle fullscreen modes)

comment:13 in reply to:  12 Changed 10 years ago by anonymous

Replying to robertm:

What happens if you turn on "scale to fit?" (Believe it's "W" to cycle fullscreen modes)

I'll give it a try and let you know

comment:14 Changed 10 years ago by judithc@…

Yes it was "W" and that worked perfectly. Images are scaled correctly :)

Thanks for all your help - it looks like this is now able to be closed

comment:15 Changed 10 years ago by robertm

Resolution: fixed
Status: infoneeded_newclosed
Note: See TracTickets for help on using tickets.