Opened 10 years ago

Closed 10 years ago

Last modified 9 years ago

#8436 closed defect (fixed)

Mythweb changing from a single title to All Programs in recordings.php isn't saved in session

Reported by: Tom Dexter <digitalaudiorock@…> Owned by: Rob Smith
Priority: minor Milestone: unknown
Component: Plugin - MythWeb Version: Unspecified
Severity: medium Keywords:
Cc: Ticket locked: no

Description

I've been debugging this one myself and am at a loss, though I think I've figured out part of what's going on.

In the recorded programs page, if I choose a program in the drop down list to filter by that program, subsequently switching to "All Programs" (that is title=) doesn't get saved in the session. At that point any time I return to the recorded programs page it's still filtered by that show unless I clear my session or expressly put refresh=1 in the query string to recorded.php.

From what I can tell, the proper empty title is in fact getting assigned to the session at line 173:

Keep track of the program/title the user wants to view

$_SESSIONrecorded_title? = $_REQUESTtitle?;

...however it appears (based on logging what's happening in the session write handler) that it's simultaneously getting overwritten with the original non empty title by the pixmaps calls that are getting the thumbnails.

Change History (4)

comment:1 Changed 10 years ago by Tom Dexter <digitalaudiorock@…>

I also just discovered that when switching from one program title in the list to another, often the old one remains in the session rather than the new one, most likely for the same reasons.

The only temporary fix I could find for this was to comment out the above mentioned line that sets the title in the session to begin with.

comment:2 Changed 10 years ago by Rob Smith

Resolution: fixed
Status: newclosed

(In [24930]) Fixes #8436, this should do the trick preventing pixmap requests from resetting the group/title view

comment:3 Changed 9 years ago by Tom Dexter <digitalaudiorock@…>

I upgraded to 0.23.1 today. I tried retrofitting the change you mention into mythweb/modules/tv/recorded.php and it didn't correct the problem. I ended up commenting out the code setting the $_SESSION.

One thing to note about that changeset: Don't forget that the php variable $_REQUEST includes the combination of $_POST, $_GET and $_COOKIES, which might explain why it's not working.

comment:4 Changed 9 years ago by Tom Dexter <digitalaudiorock@…>

Never mind. I don't know what exactly was happening with this, but once I got into debugging it I couldn't duplicate the issue, so it appears that changeset does in fact correct it.

Note: See TracTickets for help on using tickets.