Opened 10 years ago

Closed 9 years ago

#8438 closed defect (wontfix)

MythARCHIVE fails with "Cannot jump to chapter 8 of title 1, only 7 exist"

Reported by: confirm@… Owned by: paulh
Priority: minor Milestone: unknown
Component: Plugin - MythArchive Version: Unspecified
Severity: medium Keywords:
Cc: Ticket locked: no

Description

ok so it took me a while to figure this out - I've attached the logfile if you want to have a look

the problem is basically in the dvdauthor.xml file that is generated - specifically these lines:

<vob chapters="00:00:00,00:06:00,00:12:00,00:18:00,00:24:00,00:30:00,00:36:00,00:42:00," file="/home/mythtv/tmp/work/1/final.mpg"/>

notice the "chapters" attribute ends with a comma?

if I manually add another chapter point to the end of these lines (it did the same thing for every recording) then dvdauthor no longer fails with this error message

the VOB files are all created properly and the DVD is good to go

just one more thing - some of these had chapter points that were beyond the end of the recording - I ended up completely redoing all the chapter points in these cases

I don't know what part of the process generates this xml file but what a bit of modification, it should be able to get this right the first time...

Attachments (2)

mythburn.log (16.8 KB) - added by confirm@… 10 years ago.
tail end of logfile with error msg
mythburn.chapter_comma.patch (1.4 KB) - added by Raymond Wagner 10 years ago.
completely untested, but should probably work... maybe…

Download all attachments as: .zip

Change History (10)

Changed 10 years ago by confirm@…

Attachment: mythburn.log added

tail end of logfile with error msg

Changed 10 years ago by Raymond Wagner

completely untested, but should probably work... maybe...

comment:1 Changed 10 years ago by J.Pilk@…

It's a long time since I saw this error message, and when I did it was a sign of some other failure. dvdauthor may complete, but does the dvd play properly to the end?

comment:2 Changed 10 years ago by sphery

Status: newinfoneeded_new

Please test the attached patch from Raymond Wagner ( mythburn.chapter_comma.patch ) to see if it prevents the failure and makes a DVD that plays properly to the end, and let us know the results. Thanks.

comment:3 Changed 10 years ago by paulh

I don't believe that error has anything to do with the extra comma. You get it when processing a file fails part way through so the resulting video is shorter than what MythArchive? thinks it is. So say you have a 60 minute recording but the processing fails at 45 minutes and you have a chapter point set at 50 minutes then you would get an error like the error above.

comment:4 Changed 10 years ago by confirm@…

yeah I've been thinking about it and I think paulh is correct-

see I believe this is because of cut points - if I cut the last 15 minutes of a 1 hour recording, the resulting mpg is only 45 minutes long - less even, when you take out the other cut scenes - but I notice the info screen on the dvd still says 1hr - because that's the length of the original recording, according to the sql database where that information has been pulled from - and the processing fails at the last chapter point because the mpg is no longer 60 minutes long...

at least that's my current theory

comment:5 in reply to:  2 ; Changed 10 years ago by anonymous

Replying to mdean:

Please test the attached patch from Raymond Wagner ( mythburn.chapter_comma.patch ) to see if it prevents the failure and makes a DVD that plays properly to the end, and let us know the results. Thanks.

I'll give it a try overnight (takes approx 4 hrs on my machine - before it fails) and let you know what happens

thanks!

comment:6 in reply to:  5 Changed 10 years ago by anonymous

Replying to anonymous:

Replying to mdean:

Please test the attached patch from Raymond Wagner ( mythburn.chapter_comma.patch ) to see if it prevents the failure and makes a DVD that plays properly to the end, and let us know the results. Thanks.

I'll give it a try overnight (takes approx 4 hrs on my machine - before it fails) and let you know what happens

thanks!

oh no! I just realised! I transcoded all those recordings yesterday to save space (part of the process in mytharchive was to transcode them too) - so they no longer have cut scenes, which I think may actually have been the cause of this error!

ok I'll do a little experiment with some other recording (with the end cut off) and see if it fails - if it does, then I'll apply the patch and see if that fixes it...

thanks again!

comment:7 Changed 9 years ago by paulh

(In [25062]) MythArchive?: Remove the trailing comma from the chapter point creation. Patch from wagnerrp. Refs #8438.

comment:8 Changed 9 years ago by paulh

Resolution: wontfix
Status: infoneeded_newclosed

The extra comma is fixed. I don't believe it has anything to do with the original bug though.

Closing as wontfix until somebody comes up with a proper fix. A good workaround in the meantime is to use ProjectX as the cutter/demuxer.

Note: See TracTickets for help on using tickets.