Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#8442 closed defect (fixed)

sound not working (white noise) on ppc with 0.23-fixes

Reported by: michael_zanetti@… Owned by: JYA
Priority: minor Milestone: 0.24
Component: MythTV - Audio Output Version: 0.23-fixes
Severity: medium Keywords:
Cc: Ticket locked: yes

Description

I tried to upgrade my mythboxes to 0.23.

On my gentoo-powerpc machine I just get white noise as sound when watching shows. mpayer etc work fine though. The logs show nothing unusal. Video playback works fine. Just sound outputs some white noise.

I have also tried reinstalling everything with archlinuxppc. Still the same issue, so I think its really a mythtv issue

Attachments (2)

mythfrontend_sound_noise.log (10.8 KB) - added by michael_zanetti@… 9 years ago.
mythfrontend -v playback,audio
fix.endianess.patch (11.8 KB) - added by chr 9 years ago.
fix endianess, diff against release-0-23-fixes@24836

Download all attachments as: .zip

Change History (15)

comment:1 Changed 9 years ago by robertm

Status: newinfoneeded_new

We need logs with "-v playback,audio"

Changed 9 years ago by michael_zanetti@…

mythfrontend -v playback,audio

comment:2 Changed 9 years ago by anonymous

The above log is the output of "mythfrontend -v playback,audio" going straight into LiveTV and playing back a random channel for about 30 seconds. Then exited the rontend normally.

I noticed, that if there is no audio in the stream, there is also no noise. The noise comes and goes with the audio in the stream.

Perhaps an endianess problem as this happens on ppc architectures while it works on x86 machines?

Hope this helps.

comment:3 Changed 9 years ago by robertm

Component: MythTV - GeneralMythTV - Audio Output
Owner: changed from Isaac Richards to JYA
Status: infoneeded_newnew

comment:4 Changed 9 years ago by mythtv@…

Some problem here running Debian Lenny on PPC with the prebuilt MythTV packages from debian-multimedia.org (version 0.23-0.0lenny2 from May, 24th):

http://debian-multimedia.org/dists/stable/main/binary-powerpc/package/mythtv-frontend.php http://debian-multimedia.org/dists/stable/main/binary-powerpc/package/libmyth-0.23-0.php

comment:5 Changed 9 years ago by mythtv@…

I've tried to compile the newest code from http://svn.mythtv.org/svn/branches/release-0-23-fixes/mythtv (r24836).

Same problem - only white noise on Debian Lenny PPC.

comment:6 Changed 9 years ago by JYA

What is your sound configuration? Are you using the upmixer ? if so try to turn it off..

If you're compiling from source, try trunk ... audio was almost entirely rewritten

comment:7 Changed 9 years ago by michael_zanetti@…

nope... No upmixing enabled...

comment:8 Changed 9 years ago by mythtv@…

I just tried a self-compiled version (trunk r24887) and it works!

(It took some time, because I also needed to build packages for my x86 backend server, because of the new db schema)

Thanks a lot!

Hopefully, debian-multimedia.org will update their MythTV packages to trunk in the near future.

Christian

comment:9 Changed 9 years ago by JYA

Version: Unspecified0.23-fixes

It's good to know..

To be honest, I'm very surprised the 0.23 code doesn't work on PPC. Most of the work is done on 16 bits integer, so endianess isn't an issue

I have no plan of backporting the 0.24 audio code back to 0.23 ; nor do I have the equipment to properly test on PPC what's going on.

I have a Powerbook G4 1GHz somewhere in my garage, but I'm not that excited with the idea of getting linux installed on it. Sorry.

comment:10 in reply to:  9 Changed 9 years ago by anonymous

Replying to jyavenard:

It's good to know..

I have a Powerbook G4 1GHz somewhere in my garage, but I'm not that excited with the idea of getting linux installed on it.

Not necessary.

The OSX-ppc 0.23-fixes is also broken: white noise.

To my mind 16 bits integer are also an issue of endianess ...

comment:11 Changed 9 years ago by chr

I found the bug!

It came from rev23525

There is a config value "WORDS_ENDIAN" which isn't set anymore! I replaced them with "#if HAVE_BIGENDIAN" (not #ifdef) and I recompiled release-0.23-fixes on a Mac-OSX-ppc:

Sounds good :)

pS: makes me wonder that this didn't broke more than this 8)

Changed 9 years ago by chr

Attachment: fix.endianess.patch added

fix endianess, diff against release-0-23-fixes@24836

comment:12 Changed 9 years ago by JYA

Resolution: fixed
Status: newclosed

(In [25186]) Backport r25185. Fixes#8442

comment:14 Changed 9 years ago by stuartm

Milestone: unknown0.24
Ticket locked: set
Note: See TracTickets for help on using tickets.