Opened 10 years ago

Closed 10 years ago

Last modified 9 years ago

#8454 closed defect (fixed)

Border margin around pictures painted with OpenGL transitions

Reported by: Klaas de Waal <klaas.de.waal@…> Owned by: Isaac Richards
Priority: minor Milestone: 0.23-fixes
Component: Plugin - MythGallery Version: 0.23-fixes
Severity: low Keywords: margin OpenGL transitions
Cc: Ticket locked: no

Description

In the MythGallery settings you can select "Use OpenGL transitions". An unwanted side effect is that all pictures drawn by MythGallery are not full-screen but they now have a border margin of 9 pixels on all sides. This is also the case when you do not use the slide show but select the pictures individually. If the "Use OpenGL transitions" is not selected then the pictures are full-screen without border, but then of course you do not get the nice OpenGL transitions in the slide show.

The reason is that OpenGL paints into a QBoxLayout widget and this widget has by default a border margin of 9 pixels on all sides. The problem is easily fixed by setting the border margin to zero after creating the widget. This is in file glsingleview.cpp, function GLSDialog::GLSDialog.

A patch for this, tested on svn revision 24615, will be attached.

Attachments (1)

glsingleview.cpp.patch (515 bytes) - added by Klaas de Waal <klaas.de.waal@…> 10 years ago.
Patch to remove the 9-pixel border margin around pictures when using OpenGL

Download all attachments as: .zip

Change History (4)

Changed 10 years ago by Klaas de Waal <klaas.de.waal@…>

Attachment: glsingleview.cpp.patch added

Patch to remove the 9-pixel border margin around pictures when using OpenGL

comment:1 Changed 10 years ago by robertm

Resolution: fixed
Status: newclosed

(In [24662]) Fix #8454. Patch from Klaas de Waal to properly set the borders on GL display of MythGallery images to 0, eliminating the visible basebackground image border.

comment:2 Changed 10 years ago by robertm

(In [24663]) Refs #8454, backport fix for visible border in GL transitions in MythGallery to .23-fixes.

comment:3 Changed 9 years ago by stuartm

Milestone: unknown0.23-fixes
Note: See TracTickets for help on using tickets.