Opened 9 years ago

Closed 9 years ago

#8457 closed defect (fixed)

Recordings with various disabled recstatus values can break scheduling in MythWeb

Reported by: Tom Dexter <digitalaudiorock@…> Owned by: Rob Smith
Priority: minor Milestone: 0.24
Component: Plugin - MythWeb Version: Unspecified
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Recording schedules that are disabled for various reasons (in my case it was a weekly time slot schedule for a show that wasn't listed, with a recstatus of 6) can break the scheduling of a show in that time slot.

Tonight I went to schedule "Need to Know" on PBS in MythWeb. After scheduling it, it wasn't highlighted in the listings. Clicking on the program again to see the schedule showed the details as if it hadn't been scheduled (that is, no "Cancel this schedule" radio button etc). Not knowing what happened I tried to schedule it again but it still didn't show was being scheduled in the listings. I discovered that that process was creating multiple entries in the record table for that show, which could only be corrected by canceling the schedule multiple times from the frontend.

After considerable debugging I traced it to the existence of a now unlisted show (Bill Moyers Journal) in that same time slot.

I see that MythWeb currently has no sort of enumeration for recstatus entries. I've attached a patch that simply maps any recstatus values that indicate a disabled schedule and skips those when building $Scheduled_Recordings. I'm not sure of this fix, but it seems to be working.

Attachments (2)

mythweb_disabled_recstatus.patch (1.6 KB) - added by Tom Dexter <digitalaudiorock@…> 9 years ago.
mythweb-0.23-unlisted_recstatus.patch (702 bytes) - added by Tom Dexter <digitalaudiorock@…> 9 years ago.
Patch to omit unlisted entries from schedule

Download all attachments as: .zip

Change History (8)

Changed 9 years ago by Tom Dexter <digitalaudiorock@…>

comment:1 Changed 9 years ago by robertm

Status: newassigned

comment:2 Changed 9 years ago by Tom Dexter <digitalaudiorock@…>

I just happened to notice something today that I believe is a problem caused by my patch. When I did a schedule override (Don't record this specific showing) the program is showing as if it had no schedule at all, which I know didn't used to happen. I'll look into it when I get a chance.

comment:3 Changed 9 years ago by Tom Dexter <digitalaudiorock@…>

Now that I look at my change, it's omitting recstatus_dontrecord entries from the schedule.

Actually now that I look at it, I think the specific problem I had could only be caused by two shows in the same slot which (I think) could only occur due to a status 6 (recstatus_notlisted). I think the proper fix may be to simply omit them from the schedule.

Changed 9 years ago by Tom Dexter <digitalaudiorock@…>

Patch to omit unlisted entries from schedule

comment:4 Changed 9 years ago by Tom Dexter <digitalaudiorock@…>

I've uploaded what I think is a simple fix to my original issue. That is, to simply omit unlisted entries from the schedule.

comment:5 Changed 9 years ago by Rob Smith

Milestone: unknown0.24

comment:6 Changed 9 years ago by Rob Smith

Resolution: fixed
Status: assignedclosed

(In [26123]) Fixes #8457, this fixes an issue with schduled programs of recstatus_notlisted

Note: See TracTickets for help on using tickets.