Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#8464 closed defect (invalid)

Digital tuner prevents mythbackend starting

Reported by: Alex Grayson <reallytightearmuffs@…> Owned by: Janne Grunau
Priority: critical Milestone: unknown
Component: MythTV - DVB Version: Unspecified
Severity: high Keywords: dvb "Failed to bind port 6543" backend
Cc: Ticket locked: yes

Description

running ubuntu 10.04

Using analog tuners, mythtv does what it's supposed to. However, when I add an hdhomerun network tuner to the mix, I get this output when starting mythbackend.

2010-05-15 15:36:28.145 mythbackend version: branches/release-0-23-fixes [24158] www.mythtv.org
2010-05-15 15:36:28.145 Using runtime prefix = /usr
2010-05-15 15:36:28.146 Using configuration directory = /home/alex/.mythtv
2010-05-15 15:36:28.146 Empty LocalHostName.
2010-05-15 15:36:28.146 Using localhost value of mythtv-box
2010-05-15 15:36:28.154 New DB connection, total: 1
2010-05-15 15:36:28.160 Connected to database 'mythconverg' at host: localhost
2010-05-15 15:36:28.160 Closing DB connection named 'DBManager0'
2010-05-15 15:36:28.161 Connected to database 'mythconverg' at host: localhost
2010-05-15 15:36:28.165 Current MythTV Schema Version (DBSchemaVer): 1254
2010-05-15 15:36:28.166 MythBackend: Starting up as the master server.
2010-05-15 15:36:28.169 New DB connection, total: 2
2010-05-15 15:36:28.170 Connected to database 'mythconverg' at host: localhost
2010-05-15 15:36:28.176 New DB connection, total: 3
2010-05-15 15:36:28.177 Connected to database 'mythconverg' at host: localhost
2010-05-15 15:36:28.291 New DB scheduler connection
2010-05-15 15:36:28.292 Connected to database 'mythconverg' at host: localhost
2010-05-15 15:36:28.299 MediaServer::HttpServer Create Error
2010-05-15 15:36:28.299 Enabled verbose msgs:  important general
2010-05-15 15:36:28.301 AutoExpire: CalcParams(): Max required Free Space: 1.0 GB w/freq: 15 min
2010-05-15 15:36:28.302 Failed to bind port 6543. Exiting.
2010-05-15 15:36:28.302 Backend exiting, MainServer initialization error.

Also, I did a sudo killall mythbackend to ensure that all backend processes were killed and the error persists.

I am new to bug reporting, so if you need more information, please be specific on how to get it. Also, I had this same problem with ubuntu 9.10.

Change History (5)

comment:1 Changed 10 years ago by robertm

Resolution: invalid
Status: newclosed

You have another instance of the backend running. Since you are on Ubuntu, this is almost definitely upstart trying to restart it as soon as you kill it. Please follow up on the users list if you need help.

comment:2 Changed 10 years ago by Alex Grayson <reallytightearmuffs@…>

Resolution: invalid
Status: closednew

It has to be the dvb card, since backend starts normally when only using analog cards, but not when using dvb cards. Furthermore, I did a killall command then went into the frontend and got nothing. there is no backend running, or it is a partial, non-functional backend. Please don't dismiss this ticket. I'm on a fresh install of ubuntu+mythtv and this problem happens out of the box.

comment:3 in reply to:  2 Changed 10 years ago by Alex Grayson <reallytightearmuffs@…>

Edit above: Now the backend will not start at all, analog or dvb. Someone please help with this stupid problem. It happened out of the box and all anyone says is "another backend is running". At least help me get a working mythtv system.

comment:4 Changed 10 years ago by Raymond Wagner

Resolution: invalid
Status: newclosed

If it is a problem, it's a setup problem and not a bug. Please follow up on the IRC channel or mailing list for assistance.

comment:5 Changed 10 years ago by Raymond Wagner

Ticket locked: set
Note: See TracTickets for help on using tickets.