Modify
Warning Please read the Ticket HowTo before creating or commenting on a ticket. Failure to do so may cause your ticket to be rejected or result in a slower response.

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#8465 closed patch (fixed)

[PATCH] Add extra delay for rotor positioning

Reported by: Pieter Hoekstra <pieter@…> Owned by: janne
Priority: minor Milestone: 0.23-fixes
Component: MythTV - DVB Version: 0.23-fixes
Severity: medium Keywords: rotor SG-2100A diseqc
Cc: Ticket locked: no

Description

This patch increases the POWER_ON delay and adds a delay after sending the Rotor Diseqc commands.

Both delays are needed to get my setup (finally!!) working. I tried to keep the delays as low as possible;
Minimal power-on delay I needed: 900ms (Patch: 1000ms)
Minimal post-diseq delay: 75ms (Patch: 100ms)

The setup I'm using:

  • Moteck SG-2100A Rotor
  • Technisat Skystar HD2 (with s2-liplianin driver)

Attachments (3)

extra_delays_for_rotor.diff (808 bytes) - added by Pieter Hoekstra <pieter@…> 4 years ago.
Patch to fix issue
t8465_diseqc_wait_debug.diff (545 bytes) - added by janne 4 years ago.
debug patch
debug_log (63.0 KB) - added by Pieter Hoekstra <pieter@…> 4 years ago.
Log with debugpatch; mythbackend -v channel | tee debug_log

Download all attachments as: .zip

Change History (11)

Changed 4 years ago by Pieter Hoekstra <pieter@…>

Patch to fix issue

comment:1 Changed 4 years ago by janne

(In [24735]) DVB: wait 1s during diseqc initialization. Refs #8465

some specs incompliant devices seems to require this. If someone notices
increased delays please shout and I'll implement a different workaround.

comment:2 Changed 4 years ago by janne

please apply t8465_diseqc_wait_debug.diff and attach a -v channel backend log, I suspect there's a bug issuing a wait before sending the diseqc command and not after.

Changed 4 years ago by janne

debug patch

Changed 4 years ago by Pieter Hoekstra <pieter@…>

Log with debugpatch; mythbackend -v channel | tee debug_log

comment:3 Changed 4 years ago by Pieter Hoekstra <pieter@…>

I'm sorry for the late response, I have to climb on the roof with my laptop so it took a while.

The problem is that after the Rotor-commands are send, the Tuning commands are send directly after that:
2010-06-05 15:23:39.046 DiSEqCDevTree: Sending DiSEqC Command: e0 31 6b 2
2010-06-05 15:23:39.068 DVBChan(1:/dev/dvb/adapter1/frontend0): Old Params: 11856000 qpsk a auto auto a a auto a v fec: 5/6 msys: DVB-S2 rolloff: 0.25

DVBChan(1:/dev/dvb/adapter1/frontend0): New Params: 12344000 qpsk a auto auto a a auto a h fec: 3/4 msys: DVB-S rolloff: 0.35

2010-06-05 15:23:39.068 DVBChan(1:/dev/dvb/adapter1/frontend0): Tune(): Tuning to 1744000kHz

comment:4 Changed 4 years ago by robertm

  • Status changed from new to assigned

comment:5 Changed 4 years ago by Pieter Hoekstra <pieter@…>

Is there any additional information I can give or test, to get the last line of the patch included?

The delay will only occur when the rotor should move; a process which will take a few secs anyhow...

comment:6 Changed 4 years ago by janne

  • Milestone changed from unknown to 0.23-fixes
  • Status changed from assigned to accepted

comment:7 Changed 4 years ago by janne

  • Resolution set to fixed
  • Status changed from accepted to closed

(In [25973]) wait after DiSEqC rotor commands, fixes #8465

100ms should not add noticeable delay to slow rotor tuning
based on patch by: Pieter Hoekstra < pieter zoheetik com >

comment:8 Changed 4 years ago by janne

(In [25975]) backport [25973] from trunk

wait after DiSEqC rotor commands, fixes #8465

100ms should not add noticeable delay to slow rotor tuning
based on patch by: Pieter Hoekstra < pieter zoheetik com >

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'new'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.