Opened 9 years ago

Closed 9 years ago

Last modified 8 years ago

#8467 closed defect (invalid)

Sys hardlock via MythNews

Reported by: warpme@… Owned by: Isaac Richards
Priority: critical Milestone: 0.23-fixes
Component: Plugin - MythNews Version: 0.23-fixes
Severity: high Keywords:
Cc: Ticket locked: no

Description

Hi

I'm on minimyth derivate with 0.23-fixes 24609; 2.6.33.3; 195.36.24.

Entering MythNews? with attached list of RSS feeds gives solid hang of whole system (no network, no keyb) only hard reset.

Beside this exact issue, sys is stable (weeks in production on 3 different fe's).

br

Attachments (2)

newssites.sql.zip (1.1 KB) - added by warpme@… 9 years ago.
sql file with RSS sites
mythtv-master-httpool_delay.patch (1.8 KB) - added by warpme@… 8 years ago.
AddURLrequest delay patch

Download all attachments as: .zip

Change History (5)

Changed 9 years ago by warpme@…

Attachment: newssites.sql.zip added

sql file with RSS sites

comment:1 Changed 9 years ago by danielk

Resolution: invalid
Status: newclosed

Hard hangs of a system are hardware or operating system errors.

comment:2 Changed 8 years ago by warpme@…

Hi, Despite I can't verify it for 100% (as there is always probability that observation window was too short), attached patch seems to solve hard locks for me (but with price of 1 sec additional delay per bookmark). Without patch system hard locks (dead kbd, screen; only hard reset helps) approx. every few mythnews launches (it also hard locks on mythnevision, albeit I'm using my thnetvision sparadically). With attached patch I tested mythnews for 200 feeds refreshes without hard lock.

Changed 8 years ago by warpme@…

AddURLrequest delay patch

comment:3 Changed 8 years ago by beirdo

As indicated by danielk earlier, a system hang can not be directly caused by our application in any way we are aware of. Could you please open a new ticket for the followup issue?

Note: See TracTickets for help on using tickets.