Modify
Warning Please read the Ticket HowTo before creating or commenting on a ticket. Failure to do so may cause your ticket to be rejected or result in a slower response.

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#8477 closed defect (fixed)

Patchset #22999 break UPNP playback of file greater then 4G on 32 bits

Reported by: anonymous Owned by: danielk
Priority: minor Milestone: 0.24
Component: MythTV - UPnP Version: 0.23-fixes
Severity: medium Keywords: UPNP 32
Cc: Ticket locked: yes

Description

Declaration of the variable nFileSize on line 255 of the file upnpcdstv.cpp was changed from type "long long" to "size_t".

On 32 bits system, size_t cannot hold file size greater then 4G breaking the video playback of most HD recording.

Attachments (0)

Change History (9)

comment:1 Changed 4 years ago by robertm

  • Owner changed from dblain to danielk
  • Status changed from new to assigned

Daniel, reassigning to you since this was part of the programinfo refactor and david hasn't been around in a while.

comment:2 Changed 4 years ago by stuartm

  • Milestone changed from 0.23-fixes to unknown
  • Priority changed from major to minor

comment:3 Changed 4 years ago by anonymous

I had many problems playing recordings on my PS3 through UPnP. I can confirm that compiling the trunk code with the proposed modification in the bug description (changing the nFileSize variable type from “size_t” to “long long”) fixes my bug. I’m running mythbackend with a hauppauge hd-pvr on a old P4 2.0ghz.

comment:4 Changed 4 years ago by danielk

  • Resolution set to fixed
  • Status changed from assigned to closed

(In [24788]) Fixes #8477. size_t is too small on some platforms to hold a filesize. off_t should work on any UNIX99 compatible system, but I went with uint64_t since it will always be sufficiently large and we're not using this in any posix calls.

comment:5 follow-up: Changed 4 years ago by superm1@…

Could this by chance be backported to 0.23-fixes too?

comment:6 in reply to: ↑ 5 Changed 4 years ago by anonymous

Replying to superm1@…:

Could this by chance be backported to 0.23-fixes too?

I definitively need this to upgrade my system to the 0.23 version. Please include this in the 0.23-fixes (it is due in 9 days!!).

comment:7 Changed 4 years ago by anonymous

  • Resolution fixed deleted
  • Status changed from closed to new

Please include in 0.23-fixes

comment:8 Changed 4 years ago by robertm

  • Resolution set to fixed
  • Status changed from new to closed
  • Ticket locked set

Reopening closed tickets is not how to get them included.

comment:9 Changed 4 years ago by stuartm

  • Milestone changed from unknown to 0.24

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'new'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.