Opened 10 years ago

Closed 9 years ago

Last modified 9 years ago

#8506 closed defect (fixed)

mythmusic: Segfault when exiting playlist editor

Reported by: loniedavid@… Owned by: Isaac Richards
Priority: major Milestone: 0.24
Component: Plugin - MythMusic Version: Master Head
Severity: low Keywords:
Cc: Ticket locked: no

Description

To reproduce: 1) Open mythmusic 2) Open "Edit Playlist" 3) Select some tracks 4) Hit escape ...segfault. Backtrace attached.

This is using current SVN trunk (r24896).

It appears to happen when prepping the visualization, and it still happens after disabling all visualizations.

I'm setting this as major since it makes mythmusic completely useless (can't load any tracks into playlist). Of course, feel free to change this if it is incorrect.

If more information/testing is needed let me know.

Attachments (2)

gdb.txt (8.3 KB) - added by loniedavid@… 10 years ago.
gdb backtrace
disable_visuals.patch (1.2 KB) - added by Matthew Wire <devel@…> 9 years ago.
Temporary workaround

Download all attachments as: .zip

Change History (10)

Changed 10 years ago by loniedavid@…

Attachment: gdb.txt added

gdb backtrace

comment:1 Changed 10 years ago by robertm

Component: MythTV - GeneralPlugin - MythMusic
Priority: majortrivial
Severity: highlow

Please read the ticket howto, priorities and severity are to be left alone. FWIW MythMusic is in the midst of a rewrite (though we appreciate the backtrace) so it is not likely to be stable during this development cycle.

comment:2 Changed 10 years ago by JYA

Priority: trivialmajor

Have you performed a make distclean on both mythtv and mythplugins ? the libmyth API has changed a fair amount lately, and you have to make sure everything is properly recompiled.

Changing priority, as a crash is still a crash..

comment:3 Changed 10 years ago by loniedavid@…

I did a make clean distclean before grabbing the backtrace, so stale files shouldn't be an issue.

comment:4 Changed 10 years ago by JYA

I've identified the issue... This occurs when you haven't defined any visualizers.

Go in the Mytmusic preferences, in the player settings and enable some visualizers.. Will leave it as is for the time being as this is likely being rewritten

comment:5 Changed 9 years ago by Matthew Wire <devel@…>

I reported #8683 which (correctly) was marked as a duplicate of this bug.

Unfortunately it doesn't seem to matter if I have any visualizers defined or not - it still crashes. I've done some debugging and it seems to fail in the for loop of prepareVisuals() in output.cpp.

I'm attaching a patch which works around the issue for me and allows me to play CDs again - it just disables the calls to dispatchVisuals and prepareVisuals in audiooutputbase.cpp.

Changed 9 years ago by Matthew Wire <devel@…>

Attachment: disable_visuals.patch added

Temporary workaround

comment:6 Changed 9 years ago by paulh

(In [25551]) MythMusic: Tidy up the visualiser starting and stopping. Refs #8506, #8567.

comment:7 Changed 9 years ago by paulh

Resolution: fixed
Status: newclosed

(In [25560]) MythMusic: Make sure the decoder is stopped when updating the playlist and fix a leak in MusicNode?. Fixes #8506, #8567. Refs #8683.

comment:8 Changed 9 years ago by stuartm

Milestone: unknown0.24
Note: See TracTickets for help on using tickets.