Opened 10 years ago

Closed 10 years ago

#8512 closed defect (invalid)

Mythwelcome spawned frontend crashes when using internal web browser

Reported by: Mike Parker <michael.parker@…> Owned by: paulh
Priority: minor Milestone: unknown
Component: Plugin - MythBrowser Version: 0.23-fixes
Severity: medium Keywords:
Cc: Ticket locked: no

Description

I'm seeing a repeatable crash of Mythfrontend when I try to open a webpage in the internal browser. This crash only occurs if the frontend has been spawned by Mythwelcome - browsing with the internal browser is robust when the frontend is started from the command line.

Unsure which component to log this against - Mythwelcome, Mythfrontend or MythBrowser?....

Platform is F12, x86_64. I'm running 0.23-fixes from atrpms packages.

To repeat:

1) With no frontend session running, invoke Mythwelcome and let it spawn a frontend session

2) Information Center -> Web. Open a bookmarked site.

3) Web browser window starts but content is empty (blank white screen). Progress bar often reaches 50% before the frontend crashes.

Mythwelcome log and STDERR o/p attached

Attachments (3)

STDERR.log (12.0 KB) - added by Mike Parker <michael.parker@…> 10 years ago.
STDERR
mythwelcome.log (6.8 KB) - added by Mike Parker <michael.parker@…> 10 years ago.
Mythwelcome log
gdb_backtrace.txt (3.4 KB) - added by Mike Parker <michael.parker@…> 10 years ago.
GDB Backtrace

Download all attachments as: .zip

Change History (7)

Changed 10 years ago by Mike Parker <michael.parker@…>

Attachment: STDERR.log added

STDERR

Changed 10 years ago by Mike Parker <michael.parker@…>

Attachment: mythwelcome.log added

Mythwelcome log

comment:1 Changed 10 years ago by sphery

Milestone: 0.23-fixes
Priority: majorminor
Status: newinfoneeded_new

We'll need a backtrace as described at http://www.mythtv.org/wiki/Debugging . You'll likely either need to use a core file or attach gdb to the running mythfrontend process after it's started by mythwelcome.

comment:2 in reply to:  1 Changed 10 years ago by Mike Parker <michael.parker@…>

Backtrace attached, obtained after attaching gdb to the mythwelcome-invoked mythfrontend. I attempted to follow the Wiki instructions but, having found apport to be unavailable for Fedora 12, installed the ATRPMS mythtv-debuginfo package and attached gdb manually.

I'm in uncharted territory here, so please let me know if the backtrace is insufficient etc.

Changed 10 years ago by Mike Parker <michael.parker@…>

Attachment: gdb_backtrace.txt added

GDB Backtrace

comment:3 Changed 10 years ago by sphery

Please remove the IcedTeaPlugin? and retest and, if desired, install the Sun/Oracle? JDK. This looks like a problem with the OpenJDK browser plugin, not MythBrowser?. See http://www.gossamer-threads.com/lists/mythtv/dev/438733#438733

comment:4 Changed 10 years ago by sphery

Resolution: invalid
Status: infoneeded_newclosed

This doesn't seem to be a MythTV bug (see discussion on the above-mentioned thread).

The crash is caused by the IcedTeaPlugin? from OpenJDK. Using the Oracle/Sun? JDK plugin, instead, allows use of Java without crashing. Since the same crash was observed by another user who does not use mythwelcome, the crash does not seem to be specific to mythwelcome.

Note, also, that the Adobe Flash 10.1 beta (at least the 64-bit version for GNU/Linux) will crash WebKit? (up to at least Qt 4.6.2).

Note: See TracTickets for help on using tickets.