Opened 9 years ago

Closed 9 years ago

#8534 closed defect (fixed)

mythfilldatabase --refresh-all does not refresh today's data

Reported by: ylee@… Owned by: robertm
Priority: minor Milestone: 0.24
Component: MythTV - Mythfilldatabase Version: 0.23-fixes
Severity: medium Keywords:
Cc: Ticket locked: no

Description

I use SchedulesDirect? for guide data. After modifying a channel (let's call it A)'s XMLTVID and manually adding two new channels (B and C) via mythtv-setup, I ran 'mythfilldatabase --remove-new-channels --refresh-all'. All guide data for channel A was deleted but mythfilldatabase only populated it with data starting tomorrow, leaving today empty. Similarly, with B and C, only data starting tomorrow was available. Rerunning mythfilldatabase with '--remove-new-channels --refresh-today --max-days 1' filled in today's data (I do not know whether '--max-days 1' was necessary).

If '--refresh-all' is intended by design to exclude today's data please close this ticket, but I do suggest that the output of '--help' state this.

Change History (3)

comment:1 Changed 9 years ago by robertm

Owner: changed from stuartm to robertm
Status: newassigned

comment:2 Changed 9 years ago by robertm

Milestone: unknown0.24

comment:3 Changed 9 years ago by robertm

Resolution: fixed
Status: assignedclosed

Fixed in r26084.

Update help text for MythFilldatabase?? to clarify that --refresh-all is intended not to update today. This is to prevent near-term recordings from being missed as mythfilldatabase clears the current day's data, and thus requires a conscious choice by the user to clear the current data. Also clarifies that Schedules Direct users should use --dd-grab-all in this case.

Note: See TracTickets for help on using tickets.