Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#8546 closed defect (fixed)

Lossless transcode fails post libmythui-osd merge

Reported by: robertm Owned by: markk
Priority: minor Milestone: 0.24
Component: MythTV - Mythtranscode Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Noticed this regression with the branch pre-merge, and yesterday in trunk. Lossless transcode reliably fails early in the recording process, but not immediately. My theory from the little I see is that it might be failing at the skip point. Logs included, let me know if more verbosity is required.

Attachments (1)

transcodefail.log (4.5 KB) - added by robertm 9 years ago.
normal verbosity transcode fail.

Download all attachments as: .zip

Change History (9)

Changed 9 years ago by robertm

Attachment: transcodefail.log added

normal verbosity transcode fail.

comment:1 Changed 9 years ago by robertm

comment:2 Changed 9 years ago by markk

Resolution: fixed
Status: newclosed

(In [25077]) Fix lossless MPEG2 transcode following the osd branch merge.

This was caused by a slight change in behaviour in the cut list, which may now start with an 'end' marker. If this causes any other problems I may revert this commit and look at reverting to the old cut list approach.

Refs #7650. Fixes #8546.

comment:3 Changed 9 years ago by anonymous

Resolution: fixed
Status: closednew

Unfortunately lossless transcode is still broken. On a lossless transcode with the same normal cutlist as above, a four minute result video of commercials only was produced. The segment was the recording from the start (commercials) to the start of the program, which should have been where the output file actually started.

comment:4 Changed 9 years ago by sphery

Note: [25087] reverted [25077] to allow time for further testing.

comment:5 Changed 9 years ago by markk

Robert - can you try testing the patch in r25077 again (carefully!). I'm wondering if that didn't work because of another issue at the time with the treatment of bookmarks. There was some additional testing while you were away suggesting that trunk works with 25077 re-applied. Thanks.

comment:6 Changed 9 years ago by robertm

Mark,

I apologize for the slow response to this, I have been overwhelmed at work and with life. I reapplied 25077 and attempted a transcode, with correct results. I don't have anything else to test again at the moment, but I can report success with what I had.

Robert

comment:7 Changed 9 years ago by markk

Resolution: fixed
Status: newclosed

(In [25529]) Re-apply r25077 to fix lossless MPEG2 transcode. Closes #8546 again (see ticket for details).

N.B. If anyone sees unexpected results with lossless transcodes, please re-open.

comment:8 Changed 9 years ago by stuartm

Milestone: unknown0.24
Note: See TracTickets for help on using tickets.