Opened 9 years ago

Closed 9 years ago

#8552 closed defect (invalid)

Trunk - FE aborts when using MythBrowser

Reported by: r.d.vaughan@… Owned by: paulh
Priority: minor Milestone: unknown
Component: Plugin - MythBrowser Version: Master Head
Severity: medium Keywords: Mythbrowser
Cc: Ticket locked: no

Description (last modified by robertm)

Ticket information:

While using MythBrowser? the FE will crash the second time these CNet urls are used. The first time these videos play without issue. In fact the crash will also occur if any Web link is accessed then one of these CNet urls are accessed.


These CNet urls come from their RSS feeds (e.g. http://feeds.feedburner.com/cnet/cnetnewshd?format=xml). Check any URL with a <feedburner:origLink> tag.

Example: http://dw.com.com/redir/news_hd_2010-04-12-184432.m4v?destUrl=http%3A%2F%2Fcontent.cnettv.com%2Fvideo%2F287383%2Fnews_hd_2010-04-12-184432.m4v%3FADPARAMS%3DBRAND%3D47%7CSITE%3D53%7CSP%3D181%7CPOS%3D100%7CNCAT%3D%3A%3A%3A&amp;ontId=14106&amp;siteId=145&amp;edId=3&amp;asid=50086189&amp;pid=&amp;astId=31&amp;ltype=dl_dlnow


Steps to reproduce the FE abort: 1) Copy the example link above 2) Enter the FE and navigate to "Web" (MythBrowser?) 3) Add a new link with the copied URL as the link URL. 4) Click on the new link. The video will play fine. 5) Escape from the video 6) Click on the new link again. MythBrowser? will start but while loading the FE will exit.

System info: Distro: Ubuntu 9.10

> mythfrontend --version
Please attach all output as a file in bug reports.
MythTV Version   : 25079
MythTV Branch    : trunk
Network Protocol : 57
Library API      : 0.23.201000606-1
QT Version       : 4.5.2
Options compiled in:
 linux release using_oss using_alsa using_pulse using_jack using_pulseoutput using_backend using_directfb using_dvb using_firewire using_frontend using_hdhomerun using_hdpvr using_iptv using_ivtv using_joystick_menu using_lirc using_mheg using_opengl_video using_opengl_vsync using_qtdbus using_qtwebkit using_v4l using_x11 using_xrandr using_xv using_xvmc using_xvmc_vld using_xvmcw using_bindings_perl using_bindings_python using_opengl using_vdpau using_ffmpeg_threads using_live using_mheg

> mythbackend --version
Please attach all output as a file in bug reports.
MythTV Version   : 25079
MythTV Branch    : trunk
Network Protocol : 57
Library API      : 0.23.201000606-1
QT Version       : 4.5.2
Options compiled in:
 linux release using_oss using_alsa using_pulse using_jack using_pulseoutput using_backend using_directfb using_dvb using_firewire using_frontend using_hdhomerun using_hdpvr using_iptv using_ivtv using_joystick_menu using_lirc using_mheg using_opengl_video using_opengl_vsync using_qtdbus using_qtwebkit using_v4l using_x11 using_xrandr using_xv using_xvmc using_xvmc_vld using_xvmcw using_bindings_perl using_bindings_python using_opengl using_vdpau using_ffmpeg_threads using_live using_mheg

Attachments (4)

Ticket_8552.tar.gz (6.5 KB) - added by r.d.vaughan@… 9 years ago.
gdb.txt (20.7 KB) - added by robertm 9 years ago.
bt
myth.log (10.5 KB) - added by robertm 9 years ago.
log
Problem_details.txt (2.5 KB) - added by robertm 9 years ago.
details

Download all attachments as: .zip

Change History (9)

Changed 9 years ago by r.d.vaughan@…

Attachment: Ticket_8552.tar.gz added

comment:1 Changed 9 years ago by robertm

Milestone: 0.24unknown

Changed 9 years ago by robertm

Attachment: gdb.txt added

bt

Changed 9 years ago by robertm

Attachment: myth.log added

log

Changed 9 years ago by robertm

Attachment: Problem_details.txt added

details

comment:2 Changed 9 years ago by robertm

Description: modified (diff)

comment:3 Changed 9 years ago by paulh

I suspect this is more to do with the totem plugin you seem to using than MythBrowser?.

MythBrowser? without that plugin just downloads the file and then ignores it since it doesn't know what to do with the downloaded file.

If the internal player can play it then maybe we should have MythBrowser? open it using that rather than rely on some external browser plugin?

comment:4 Changed 9 years ago by r.d.vaughan@…

Thanks for the explanation. This ticket can be closed.

comment:5 Changed 9 years ago by robertm

Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.