Opened 9 years ago

Closed 9 years ago

#8563 closed defect (Duplicate)

AFD Error: Unknown audio decoding error

Reported by: cristian.rodriguez@… Owned by: Janne Grunau
Priority: major Milestone: unknown
Component: MythTV - Audio Output Version: Master Head
Severity: high Keywords: ISDB-Tb alsa
Cc: Ticket locked: yes

Description

I live in Chile, where we use ISDB-Tb, Im trying to get Mythtv trunk running, with USB adapter "Mygyca S870" detected and working

7.533423] DVB: registering adapter 0 frontend 0 (DiBcom? 8000 ISDB-T)...

[ 7.719870] DiB0090: successfully identified [ 7.719924] input: IR-receiver inside an USB DVB receiver as /devices/pci0000:00/0000:00:1a.7/usb1/1-4/input/input7 [ 7.719960] dvb-usb: schedule remote query interval to 50 msecs. [ 7.719963] dvb-usb: DiBcom? STK8096GP reference design successfully initialized and connected.

It works with no issue with VLC player, but the following happends on MythTv?.

a) video works perfectly. b) No matter what I do, audio fails to work

Current log

2010-06-14 11:07:22.203 VDPAU Painter: Clearing VDPAU painter cache. 2010-06-14 11:07:22.260 VDPAU: Created 2 output surfaces. 2010-06-14 11:07:22.260 VDPAU: Created VDPAU render device 1920x1080 2010-06-14 11:07:22.301 NVP(0): Forcing decode extra audio option on (Video method requires it). 2010-06-14 11:07:22.301 AFD: Opened codec 0x7f8754e44860, id(H264) type(Video) 2010-06-14 11:07:22.301 AFD: codec AAC/LATM has 2 channels 2010-06-14 11:07:22.301 AFD: Opened codec 0x7f8754e77200, id(AAC/LATM) type(Audio) 2010-06-14 11:07:22.382 AO: Resampling from 88 kHz to 48 kHz with quality medium 2010-06-14 11:07:22.382 AO: Opening audio device 'mixed-digital' ch 2(2) sr 48000 sf signed 16 bit reenc 0 2010-06-14 11:07:22.407 Opening ALSA audio device 'mixed-digital'. 2010-06-14 11:07:22.490 VDPAU: Added 2 output surfaces (total 4, max 4) 2010-06-14 11:07:22.687 AFD Error: Unknown audio decoding error 2010-06-14 11:07:22.747 AFD Error: Unknown audio decoding error

No digital, no analog sound works at all.

Change History (17)

comment:1 Changed 9 years ago by robertm

Resolution: invalid
Status: newclosed

Please start by asking for help on the users list, all this seems to indicate that your locale uses LATM audio, which requires compiling in libfaad support.

comment:2 Changed 9 years ago by anonymous

Libfaad support is already enabled, audio is according to the standards

LC AAC@L4 ; HE-AAC+SBRv.1@L2; HE-AAC+SBRv.1@L4

comment:3 Changed 9 years ago by anonymous

In this particular case, is HE-AAC+SBRv.1

comment:4 Changed 9 years ago by JYA

You need to compile myth with LATM/AAC support. Check the configure option

comment:5 Changed 9 years ago by anonymous

Seems like there is misunderstanding here, I already did my homework and even submitted a patch to mythtv, Im 100% sure this is _NOT_ an user error.

grep LATM * config.h:#define CONFIG_LIBFAAD_LATM_DECODER 1 config.h:#define CONFIG_LATM_PARSER 1 config.mak:CONFIG_LIBFAAD_LATM_DECODER=yes config.mak:CONFIG_LATM_PARSER=yes

libfaad, libfaac and everything that is needed to support it is already enabled, my wild guess is that some builtin library you ship is outdated.

I have the latest multimedia libraries installed as well current mythtv trunk

0-06-28 20:15:27.603 NVP(0): Forcing decode extra audio option on (Video method requires it).
2010-06-28 20:15:27.603 AFD: Opened codec 0x24fc570, id(H264) type(Video)
2010-06-28 20:15:27.603 AFD: codec AAC/LATM has 2 channels
2010-06-28 20:15:27.603 AFD: Opened codec 0x250bc40, id(AAC/LATM) type(Audio)
2010-06-28 20:15:27.603 AFD: Audio Track #1 is A/V stream #1 and has 2 channels in the Undetermined language(7695972).
2010-06-28 20:15:27.613 AFD: Selected track 1: Undetermined LIBFAAD_LATM 2ch (A/V Stream #1)
2010-06-28 20:15:27.613 AFD: Initializing audio parms from audio track #1
2010-06-28 20:15:27.613 AFD: Audio format changed 
                        from id(NONE)     -1Hz -1ch -1bps     to id(AAC/LATM)  88200Hz  2ch 16bps    
2010-06-28 20:15:27.613 AO: SetEffDsp: 8820000
2010-06-28 20:15:27.613 AO: Killing AudioOutputDSP
2010-06-28 20:15:27.613 AO: OutputAudioLoop: Stop Event
2010-06-28 20:15:27.613 AO: kickoffOutputAudioLoop exiting
2010-06-28 20:15:27.613 AO: Original codec was AAC/LATM, signed 16 bit, 88 kHz, 2 channels
2010-06-28 20:15:27.613 AO: Resampling from 88 kHz to 48 kHz with quality medium
2010-06-28 20:15:27.613 AO: Audio processing enabled
2010-06-28 20:15:27.613 AO: Opening audio device 'mixed-digital' ch 2(2) sr 48000 sf signed 16 bit reenc 0
2010-06-28 20:15:27.613 ALSA: Setting IEC958 status: audio
2010-06-28 20:15:27.614 Opening ALSA audio device 'mixed-digital'.
2010-06-28 20:15:27.615 ALSA: SetParameters(format=2, channels=2, rate=48000, buffer_time=100000, period_time=50000)
2010-06-28 20:15:27.615 ALSA: Buffer time = 85333 us
2010-06-28 20:15:27.615 ALSA: Period time = 21333 us
2010-06-28 20:15:27.615 ALSA: Buffer size = 4096 | Period size = 1024
2010-06-28 20:15:27.615 AO: Audio fragment size: 2048
2010-06-28 20:15:27.615 AO: Audio Stretch Factor: 1
2010-06-28 20:15:27.615 AO: Ending Reconfigure()
2010-06-28 20:15:27.615 AO: kickoffOutputAudioLoop: pid = 27824
2010-06-28 20:15:27.615 AO: OutputAudioLoop: Play Event
2010-06-28 20:15:27.674 AO: Pause 0
2010-06-28 20:15:27.674 AO: Pause 1
2010-06-28 20:15:27.675 AO: OutputAudioLoop: audio paused
2010-06-28 20:15:27.699 AFD Error: Unknown audio decoding error
2010-06-28 20:15:27.699 AFD Error: Unknown audio decoding error

Is the result, no matter what audio device is used, either digital or analog.

comment:6 Changed 9 years ago by JYA

Owner: changed from JYA to Janne Grunau

2010-06-28 20:15:27.699 AFD Error: Unknown audio decoding error

means ffmpeg libraries are unable to decode the audio. This is not an audio playback error.

If you have run configure with --enable-libfaad and latm is in..

the issue is in ffmpeg.

Please provide a sample..

comment:7 Changed 9 years ago by crrodriguez@…

Resolution: invalid
Status: closednew

Ok, I will upload a sample, asap, any hope of unbundling libav* or a configure option to use system's ffmpeg which does not have this bug ? (mplayer, vlc, and others are able to do the job just fine)

comment:8 Changed 9 years ago by nachokb@…

Hi, I'm from Argentina. We're using the same norm, and I have the same problem, so I uploaded two clips with this problem (see below).

Both of them work flawlessly in VLC, but MythTV keeps throwing "AFD Error: Unknown audio decoding error".

Hope it's useful,

nachokb

http://www.4shared.com/dir/tWwaJOti/mythtv.html

comment:9 Changed 9 years ago by nachokb@…

noone here?

comment:10 Changed 9 years ago by robertm

Status: newassigned

comment:11 Changed 9 years ago by crrodriguez@…

nachokb: If a fix is issued, please test it , Im currently unable to verify fix, experimental ISDB-T transmission has gone off air in my city and it is unlikely to return this year.

comment:12 Changed 9 years ago by nachokb@…

@crrodriguez sorry to hear that, will test it further. In the last weeks a few additional stations were added, and a few of them with different results (in some I can hear audio, but it's slower than realtime).

I'm starting to think that there's something wrong with the broadcasts (though they can be watched with VLC).

I'll upload some new samples which show these new issues later.

In the meantime, what tool do you use to analyze the streams?

Thanks,

nachokb

comment:13 Changed 9 years ago by anonymous

sorry for not updating this, I'm not receiving some test signals anymore... they were interesting because I could hear audio on them, though pitched either too slow or too fast...

comment:14 Changed 9 years ago by hbugallo@…

Hello nachokb, I live in argentina and I have the same DTV dongle (mygica s870). I can't get audio works with mythtv ...but yes, video works ok. I would like to know if anyone has success with this. As far I know, Argentina, Uruguay, Chile, Perú, Bolivia, and more, have the same issue, it's ok with video but no audio at all. Thanks in advance, Hernán

comment:15 in reply to:  14 Changed 9 years ago by nachokb@…

Replying to hbugallo@…:

Hello nachokb, I live in argentina and I have the same DTV dongle (mygica s870). I can't get audio works with mythtv ...but yes, video works ok. I would like to know if anyone has success with this. As far I know, Argentina, Uruguay, Chile, Perú, Bolivia, and more, have the same issue, it's ok with video but no audio at all. Thanks in advance, Hernán

Hi Hernán,

I still couldn't make it work (tried different versions of MythTV, etc). Video ok, no audio.

There was a moment though (when they started broadcasting on channels 22, 23, 25) in which there were *some* which had audio, though it was buggy (it played slowly basically). As I don't have a nice signal (nor a decent antenna) I can't really test that much right now (a new, hopefully better, though indoor antenna is being shipped to me as we speak).

In the end, I think there's something wrong either with the way it's being broadcast, or there a bug in MythTV supporting LATM HE-AAC bitstreams.

Thanks,

nachokb

comment:16 Changed 9 years ago by nachokb@…

Hopefully Maverick with newer ffmpeg libs will help though (crosses fingers)...

nachokb

comment:17 Changed 9 years ago by beirdo

Resolution: Duplicate
Status: assignedclosed
Ticket locked: set

At this point, there is no LATM support in mythtv at all. There is a bug open for this (#9064). Please move discussion to the mailing lists rather than here. The newer ffmpeg libs that have been merged into mythtv actually removed the LATM support we had, and it needs to be put back in.

I'm marking this as a duplicate of #9064, and putting a reference in it back to here for reference.

Note: See TracTickets for help on using tickets.