Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#8573 closed defect (fixed)

mythfrontend segfault on mythvideo playback of avi encoded with aac using the Internal player

Reported by: Achim Andreas von Roznowski <mythtv@…> Owned by: Janne Grunau
Priority: minor Milestone: 0.24
Component: MythTV - Video Playback Version: 0.23-fixes
Severity: medium Keywords:
Cc: Ticket locked: no

Description

mythfrontend crashes when playing my home videos using the Internal player, if they were encoded (from dvsd) to h.264 & aac using avidemux. It plays the same content encoded to mpv and mpa without problems. VLC, mplayer, kaffeine all play both codecs without problems.

Attached are the two files used to demonstrate and reproduce the problem.

The segfault output on the command line indicates a problem occurring in libfaad:

2010-06-17 14:50:44.220 [libfaad @ 0x7f222ac683c0]libfaad: frame decoding failed: Bitstream value not allowed by specification Segmentation fault

Steps to reproduce the problem:

  1. encode a video using avidemux with h264 and aac
  2. add the encoded file to mythvideo database
  3. play the file using Internal player
  4. mythfrontend crashes with above message

Complete command line output using mythfrontend -v playback:

2010-06-17 15:01:33.212 TV: Attempting to change from None to WatchingVideo? 2010-06-17 15:01:33.213 RingBuf?(myth://Videos@mythback1:6543/other/mythvideo_testcase.h264_aac.avi): OpenFile?(myth://Videos@mythback1:6543/other/mythvideo_testcase.h264_aac.avi, 12) 2010-06-17 15:01:33.344 RingBuf?(myth://Videos@mythback1:6543/other/mythvideo_testcase.h264_aac.avi): CalcReadAheadThresh?(0 KB)

-> threshhold(64 KB) min read(0 KB) blk size(32 KB)

2010-06-17 15:01:33.400 TV: StartPlayer?(0, WatchingVideo?, main) -- begin 2010-06-17 15:01:33.400 TV: Elapsed time since TV constructor was called: 346 ms 2010-06-17 15:01:34.979 RingBuf?(myth://Videos@mythback1:6543/other/mythvideo_testcase.h264_aac.avi): Waited 1.0 seconds for data to become available... 2010-06-17 15:01:35.981 RingBuf?(myth://Videos@mythback1:6543/other/mythvideo_testcase.h264_aac.avi): Waited 2.0 seconds for data to become available... 2010-06-17 15:01:36.419 [libfaad @ 0x7f98ec5283c0]libfaad: frame decoding failed: Bitstream value not allowed by specification Segmentation fault

andrev@mythback1:~> mythfrontend --version Please attach all output as a file in bug reports. MythTV Version : 0.23 MythTV Branch : tags/release-0-23 Network Protocol : 56 Library API : 0.23.20100429-1 QT Version : 4.5.3 Options compiled in:

linux release using_oss using_alsa using_pulse using_jack using_pulseoutput using_backend using_dvb using_firewire using_frontend using_hdhomerun using_hdpvr using_iptv using_ivtv using_joystick_menu using_libfftw3 using_lirc using_mheg using_opengl_video using_opengl_vsync using_qtdbus using_qtwebkit using_v4l using_x11 using_xrandr using_xv using_xvmc using_xvmc_vld using_xvmcw using_bindings_perl using_bindings_python using_opengl using_vdpau using_ffmpeg_threads using_libavc_5_3 using_live using_mheg

andrev@mythback1:~>

Attachments (2)

mythvideo_testcase.h264_aac.avi (484.0 KB) - added by Achim Andreas von Roznowski <mythtv@…> 9 years ago.
mythvideo_testcase_truncated.avi (392.3 KB) - added by Achim Andreas von Roznowski <mythtv@…> 9 years ago.

Download all attachments as: .zip

Change History (5)

Changed 9 years ago by Achim Andreas von Roznowski <mythtv@…>

Changed 9 years ago by Achim Andreas von Roznowski <mythtv@…>

comment:1 Changed 9 years ago by robertm

Component: Plugin - MythVideoMythTV - Video Playback
Owner: changed from Anduin Withers to Janne Grunau

comment:2 Changed 9 years ago by robertm

Resolution: fixed
Status: newclosed

Working in trunk.

comment:3 Changed 9 years ago by stuartm

Milestone: unknown0.24
Note: See TracTickets for help on using tickets.