Opened 14 years ago

Closed 14 years ago

#858 closed patch (fixed)

Clicking on a channel in the mythweb listings brings back details from 1970

Reported by: abostock@… Owned by: xris
Priority: minor Milestone: 0.19
Component: mythweb Version: head
Severity: low Keywords:
Cc: Ticket locked: no

Description

Using SVN 8355 Clicking on a channel name/logo/number in the mythweb listings brings back details from 1970. The following patch fixes this, the problem is just that ?chanid= is missing in the url.

--- ./themes/default/tv/list.php        2005-12-23 09:00:57.000000000 +0000
+++ /usr/local/mythtv/mythplugins/mythweb/themes/default/tv/list.php    2005-12-18 16:19:12.000000000 +0000
@@ -138,25 +138,25 @@
             if (show_channel_icons === true) {
         ?><table class="small" width="100%" border="0" cellspacing="0" cellpadding="2">
         <tr>
-            <td width="50%" align="center" nowrap><a href="<?php echo root ?>tv/channel?chanid=<?php echo $channel->chanid ?>&time=<?php echo $list_starttime ?>" class  ="huge"
+            <td width="50%" align="center" nowrap><a href="<?php echo root ?>tv/channel/<?php echo $channel->chanid ?>&time=<?php echo $list_starttime ?>" class="huge"
                                             onmouseover="return wstatus('Details for: <?php echo preg_replace("/([\"'])/", '\\\$1', $channel->channum.' '.$channel->cal  lsign) ?>')"
                                             onmouseout="return wstatus('')"><?php echo prefer_channum ? $channel->channum : $channel->callsign ?></a>&nbsp;</td>
             <td width="50%" align="right"><?php
                 if (is_file($channel->icon)) {
-                    ?><a href="<?php echo root ?>tv/channel?chanid=<?php echo $channel->chanid ?>&time=<?php echo $list_starttime ?>"
+                    ?><a href="<?php echo root ?>tv/channel/<?php echo $channel->chanid ?>&time=<?php echo $list_starttime ?>"
                         onmouseover="return wstatus('<?php echo t('Details for') ?>: <?php echo preg_replace("/([\"'])/", '\\\$1', $channel->channum.' '.$channel->call  sign) ?>')"
                         onmouseout="return wstatus('')"><img src="<?php echo $channel->icon ?>" height="30" width="30"></a><?php
                 } else {
                     echo '&nbsp;';
                 } ?></td>
         </tr><tr>
-            <td colspan="2" align="center" nowrap><a href="<?php echo root ?>tv/channel?chanid=<?php echo $channel->chanid ?>&time=<?php echo $list_starttime ?>"
+            <td colspan="2" align="center" nowrap><a href="<?php echo root ?>tv/channel/<?php echo $channel->chanid ?>&time=<?php echo $list_starttime ?>"
                                             onmouseover="window.status='Details for: <?php echo preg_replace("/([\"'])/", '\\\$1', $channel->channum.' '. $channel->cal  lsign) ?>';return true"
                                             onmouseout="window.status='';return true"><?php echo prefer_channum ? $channel->callsign : $channel->channum ?></a></td>
         </tr>
         </table><?php
             } else {
-        ?><a href="<?php echo root ?>tv/channel?chanid=<?php echo $channel->chanid ?>" class="huge"
+        ?><a href="<?php echo root ?>tv/channel/<?php echo $channel->chanid ?>" class="huge"
             onmouseover="window.status='Details for: <?php echo $channel->channum ?> <?php echo $channel->callsign ?>';return true"
             onmouseout="window.status='';return true"><?php echo prefer_channum ? $channel->channum : $channel->callsign ?><BR>
         <?php echo prefer_channum ? $channel->callsign : $channel->channum ?></a><?php

Change History (2)

comment:1 Changed 14 years ago by xris

Actually, looks like your patch is backwards.. plus, that isn't the issue. new mod_rewrite format allows the way it is. There are, however, some typos, which will be corrected shortly.

comment:2 Changed 14 years ago by xris

Resolution: fixed
Status: newclosed

(In [8419]) fix the channel links so dates get loaded properly. closes #858

Note: See TracTickets for help on using tickets.