Opened 10 years ago

Closed 10 years ago

#8587 closed defect (duplicate)

0.23-fixes fails to build against QT 4.7.0

Reported by: superm1@… Owned by: dblain
Priority: minor Milestone: 0.23-fixes
Component: MythTV - UPnP Version: 0.23-fixes
Severity: medium Keywords:
Cc: Ticket locked: no

Description

A recent snapshot of 0.23-fixes (25145) was uploaded to Ubuntu Maverick and is failing to build libmythupnp. The same build works fine against the QT in Ubuntu Lucid (4.6.2).

Here's where it's failing:

ccache g++ -c -pipe -fomit-frame-pointer -march=i686 -g -Wall -Wno-switch -Wpointer-arith -Wredundant-decls -Wno-non-virtual-dtor -funit-at-a-time -DSTDC_CONSTANT_MACROS -D_REENTRANT -DPIC -fPIC -DMMX -Di386 -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -DQT_SQL_LIB -DQT_XML_LIB -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB -DQT_SHARED -I/usr/share/qt4/mkspecs/linux-g++ -I. -I/usr/include/qt4/QtCore -I/usr/include/qt4/QtNetwork -I/usr/include/qt4/QtGui -I/usr/include/qt4/QtXml -I/usr/include/qt4/QtSql -I/usr/include/qt4 -I/usr/include -I/usr -I../libmythdb -I.. -I. -o upnpcmgr.o upnpcmgr.cpp In file included from upnpcmgr.h:29,

from upnpcmgr.cpp:26:

eventing.h: In member function 'T StateVariables::GetValue?(const QString&) [with T = QString]': upnpcmgr.cpp:69: instantiated from here eventing.h:236: error: call of overloaded 'QString(int)' is ambiguous /usr/include/qt4/QtCore/qstring.h:428: note: candidates are: QString::QString(const QByteArray&) /usr/include/qt4/QtCore/qstring.h:426: note: QString::QString(const char*) /usr/include/qt4/QtCore/qstring.h:727: note: QString::QString(const QString&) /usr/include/qt4/QtCore/qstring.h:106: note: QString::QString(QChar) /usr/include/qt4/QtCore/qstring.h:105: note: QString::QString(const QChar*) eventing.h:244: error: call of overloaded 'QString(int)' is ambiguous /usr/include/qt4/QtCore/qstring.h:428: note: candidates are: QString::QString(const QByteArray&) /usr/include/qt4/QtCore/qstring.h:426: note: QString::QString(const char*) /usr/include/qt4/QtCore/qstring.h:727: note: QString::QString(const QString&) /usr/include/qt4/QtCore/qstring.h:106: note: QString::QString(QChar) /usr/include/qt4/QtCore/qstring.h:105: note: QString::QString(const QChar*) make[4]: * [upnpcmgr.o] Error 1 make[4]: Leaving directory `/build/buildd/mythtv-0.23.0+fixes25145/libs/libmythupnp' make[3]: * [sub-libmythupnp-make_default] Error 2 make[3]: * Waiting for unfinished jobs....

The full build log is available at http://launchpadlibrarian.net/50654589/buildlog_ubuntu-maverick-i386.mythtv_0.23.0%2Bfixes25145-0ubuntu0%2Bmythbuntu3_FAILEDTOBUILD.txt.gz

Change History (2)

comment:1 Changed 10 years ago by achew22+mythtv@…

I think this is a dupe of #8572

comment:2 Changed 10 years ago by sphery

Resolution: duplicate
Status: newclosed

dup of #8572

Note: See TracTickets for help on using tickets.