Opened 9 years ago

Closed 9 years ago

#8596 closed defect (Fixed)

No audio with DVB recording with 2 audio tracks (0 channels)

Reported by: otto at kolsi dot fi Owned by: danielk
Priority: minor Milestone: unknown
Component: MythTV - Audio Output Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

With particular recording, there's no audio if playback is started from the middle of the program (bookmark). When playing from the beginning, audio works fine. This recording has 2 tracks but both are identified to have 0 channels. I've attached logs with "-v important,general,audio".

Similar issue was last fixed 3 years ago: #3731.

Attachments (1)

mfe-no-audio.txt (4.2 KB) - added by otto at kolsi dot fi 9 years ago.

Download all attachments as: .zip

Change History (10)

Changed 9 years ago by otto at kolsi dot fi

Attachment: mfe-no-audio.txt added

comment:1 Changed 9 years ago by JYA

Owner: changed from JYA to markk
Status: newassigned

This issue is avfd related. Not sure who's best to handle it, Markk or Janne

comment:2 Changed 9 years ago by markk

Resolution: fixed
Status: assignedclosed

(In [25269]) Reinstate a small audio format check that got lost in the OSD merge.

Closes #8596

comment:3 Changed 9 years ago by otto at kolsi dot fi

Resolution: fixed
Status: closednew

This no-audio problem is still present with current trunk. I've uploaded sample file (35M) to: http://filebin.ca/thvvek

Problem should occur with following steps:

  • import sample file into recordings using myth.rebuilddatabase.pl and let it re-build the seektable
  • start to watch the recording from the beginning
  • when the actual program starts (a man within church), exit recording and save a bookmark
  • go back to watch the recording from the bookmark -> no audio!

I first tried to cut a smaller sample from the middle of the program but couldn't reproduce the problem with it. It looks like problem maybe happens because of some track changes etc. in the beginning when the program starts..

comment:4 Changed 9 years ago by robertm

Owner: changed from markk to JYA
Status: newassigned

Appears related to the other bug where audio format changes somewhere in the stream.

comment:5 Changed 9 years ago by JYA

Owner: JYA deleted
Status: assignednew

I've been able to reproduce the problem by marking a bookmark when you see the man praying with a rosary. You then exit and come back.

Log will show that audio is being opened with: (Video) already open. 2010-09-13 14:54:18.201 AFD: Warning, audio codec 0x9133090 id(MP3) type (Audio) already open, leaving it alone. 2010-09-13 14:54:18.201 AFD: codec MP3 has 0 channels 2010-09-13 14:54:18.201 AFD: Audio Track #1 is A/V stream #1 and has 0 channels in the English language(6647399). 2010-09-13 14:54:18.201 AFD: Warning, audio codec 0x3a80070 id(MP3) type (Audio) already open, leaving it alone. 2010-09-13 14:54:18.201 AFD: codec MP3 has 0 channels 2010-09-13 14:54:18.201 AFD: Audio Track #2 is A/V stream #2 and has 0 channels in the Dutch; Flemish language(6583668). 2010-09-13 14:54:18.201 AFD: Trying to select audio track (w/lang) 2010-09-13 14:54:18.201 AFD: Selected track 1: English MP0 ?ch (A/V Stream #1) 2010-09-13 14:54:18.201 AFD: Initializing audio parms from audio track #1 2010-09-13 14:54:18.201 AFD: Audio format changed

from id(NONE) -1Hz -1ch -1bps to id( MP3) 0Hz 0ch 16bps

So AFVD tries to open the audio card with 0Hz , 0 channels which is obviously not valid.

Re-assigning to someone else, this is related to libavcodec usage in avfd. It is different to the issue of having an AC3 stream going 6->2->6->2 etc...

comment:6 Changed 9 years ago by beirdo

Owner: set to danielk
Status: newassigned

comment:7 Changed 9 years ago by otto at kolsi dot fi

Just verified that the no-audio issue is still present with latest r26882

comment:8 Changed 9 years ago by otto@…

This issue seems to be working now, has been fixed somewhere between r26882 and current head. Ticket can be closed.

comment:9 Changed 9 years ago by JYA

Resolution: Fixed
Status: assignedclosed

can't imagine why this would be fixed .. but I'm certainly not going to argue about it

Note: See TracTickets for help on using tickets.